source: npl/phone/asterisk_testsuite/asterisk_testsuite.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1016 bytes
Line 
1#!/bin/bash
2#DEP:svn
3#DEP:lua_dev
4#DEP:lua
5
6NAME=asterisk_testsuite
7BRANCH=1.4
8CWD=`pwd`
9PKGTMP=/tmp/asterisk-testsuite-package
10TMP=$CWD
11
12mkdir -p $TMP &>/dev/null
13cd $TMP
14
15#downloading the sorce
16svn co http://svn.asterisk.org/svn/testsuite/asterisk/trunk testsuite || exit 1
17VER=`svnversion testsuite` || exit 1
18
19export MAKEFLAGS=-j1
20
21#patch the testsuite
22patch -F3 -p0 < testsuite-nosourcecheck.patch || exit 1
23mkdir -p $PKGTMP/usr/ || exit 1
24
25#make install Asttest, which is part of Asterisk testsuite
26MAKEOPTS=""
27cd testsuite/asttest
28make pkgconfigdir=/usr/lib/pkgconfig install_prefix=$PKGTMP DESTDIR=$PKGTMP INSTALL_ROOT=$PKGTMP install_root=$PKGTMP $MAKE_OPTS install || exit 1
29cd ../../
30
31#cleanup .svn
32for n in `find . -type d  | grep ".svn"` ; do rm -rf $n ; done || exit 1
33
34#copy testsuite
35cp -r testsuite $PKGTMP/usr/asterisk_testsuite | exit 1
36
37syn3_strip $PKGTMP || exit 1
38
39cd "$PKGTMP" || exit 1
40makepkg -l n -c n $CWD/$NAME.pkg > /dev/null &&
41echo $VER > $CWD/$NAME.version &&
42arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.