gcc484ntopperl-5.22
Last change
on this file since c5c522c was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
1016 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | #DEP:svn |
---|
3 | #DEP:lua_dev |
---|
4 | #DEP:lua |
---|
5 | |
---|
6 | NAME=asterisk_testsuite |
---|
7 | BRANCH=1.4 |
---|
8 | CWD=`pwd` |
---|
9 | PKGTMP=/tmp/asterisk-testsuite-package |
---|
10 | TMP=$CWD |
---|
11 | |
---|
12 | mkdir -p $TMP &>/dev/null |
---|
13 | cd $TMP |
---|
14 | |
---|
15 | #downloading the sorce |
---|
16 | svn co http://svn.asterisk.org/svn/testsuite/asterisk/trunk testsuite || exit 1 |
---|
17 | VER=`svnversion testsuite` || exit 1 |
---|
18 | |
---|
19 | export MAKEFLAGS=-j1 |
---|
20 | |
---|
21 | #patch the testsuite |
---|
22 | patch -F3 -p0 < testsuite-nosourcecheck.patch || exit 1 |
---|
23 | mkdir -p $PKGTMP/usr/ || exit 1 |
---|
24 | |
---|
25 | #make install Asttest, which is part of Asterisk testsuite |
---|
26 | MAKEOPTS="" |
---|
27 | cd testsuite/asttest |
---|
28 | make pkgconfigdir=/usr/lib/pkgconfig install_prefix=$PKGTMP DESTDIR=$PKGTMP INSTALL_ROOT=$PKGTMP install_root=$PKGTMP $MAKE_OPTS install || exit 1 |
---|
29 | cd ../../ |
---|
30 | |
---|
31 | #cleanup .svn |
---|
32 | for n in `find . -type d | grep ".svn"` ; do rm -rf $n ; done || exit 1 |
---|
33 | |
---|
34 | #copy testsuite |
---|
35 | cp -r testsuite $PKGTMP/usr/asterisk_testsuite | exit 1 |
---|
36 | |
---|
37 | syn3_strip $PKGTMP || exit 1 |
---|
38 | |
---|
39 | cd "$PKGTMP" || exit 1 |
---|
40 | makepkg -l n -c n $CWD/$NAME.pkg > /dev/null && |
---|
41 | echo $VER > $CWD/$NAME.version && |
---|
42 | arch > $CWD/$NAME.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.