[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | |
---|
| 7 | #Strict build-dependencies |
---|
| 8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
| 9 | #(this is recommended for most dependencys) |
---|
| 10 | ##DEP:linux |
---|
| 11 | ##DEP:linux_src |
---|
| 12 | ##DEP:openldap |
---|
| 13 | |
---|
| 14 | #Loose build-dependencies |
---|
| 15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
| 16 | #(not recommended) |
---|
| 17 | ##NEED:doxygen |
---|
| 18 | |
---|
| 19 | #######Essential package info. |
---|
| 20 | #Change these if autodetection fails. |
---|
| 21 | |
---|
| 22 | #Name of the Syn-3 package that we are going to create |
---|
| 23 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 24 | |
---|
| 25 | #Version of the sourcefiles |
---|
| 26 | VER="1.0" |
---|
| 27 | |
---|
| 28 | #Architecture that the created binaries run on. |
---|
| 29 | #Use noarch for scripts. |
---|
| 30 | ARCH=`uname -m` |
---|
| 31 | |
---|
| 32 | #from this point on, exit on errors: |
---|
| 33 | set -e |
---|
| 34 | |
---|
| 35 | mkdir -p /tmp/pkg/var/lib/asterisk/scripts &>/dev/null || exit 1 |
---|
| 36 | cp fax2email /tmp/pkg/var/lib/asterisk/scripts/fax2email.new || exit 1 |
---|
| 37 | cp fax2email.README /tmp/pkg/var/lib/asterisk/scripts || exit 1 |
---|
| 38 | mkdir -p /tmp/pkg/etc/postinst.d || exit 1 |
---|
| 39 | cp post.fax2email /tmp/pkg/etc/postinst.d || exit 1 |
---|
| 40 | chmod +x /tmp/pkg/etc/postinst.d/post.fax2email || exit 1 |
---|
| 41 | mkdir -p /tmp/pkg/etc/cron.daily/ || exit 1 |
---|
| 42 | cp faxspool-cleaner.sh /tmp/pkg/etc/cron.daily/ || exit 1 |
---|
| 43 | chmod +x /tmp/pkg/etc/cron.daily/faxspool-cleaner.sh || exit 1 |
---|
| 44 | |
---|
| 45 | #make main package |
---|
| 46 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 47 | |
---|
| 48 | |
---|
| 49 | |
---|