source: npl/phone/fax2email_script/fax2email_script.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.6 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#######Essential package info.
20#Change these if autodetection fails.
21
22#Name of the Syn-3 package that we are going to create
23NAME=`basename $0|sed 's/.SlackBuild//'`
24
25#Version of the sourcefiles
26VER="1.0"
27
28#Architecture that the created binaries run on.
29#Use noarch for scripts.
30ARCH=`uname -m`
31
32#from this point on, exit on errors:
33set -e
34
35mkdir -p /tmp/pkg/var/lib/asterisk/scripts &>/dev/null || exit 1
36cp fax2email /tmp/pkg/var/lib/asterisk/scripts/fax2email.new || exit 1
37cp fax2email.README /tmp/pkg/var/lib/asterisk/scripts || exit 1
38mkdir -p /tmp/pkg/etc/postinst.d || exit 1
39cp post.fax2email /tmp/pkg/etc/postinst.d || exit 1
40chmod +x /tmp/pkg/etc/postinst.d/post.fax2email || exit 1
41mkdir -p /tmp/pkg/etc/cron.daily/ || exit 1
42cp faxspool-cleaner.sh /tmp/pkg/etc/cron.daily/ || exit 1
43chmod +x /tmp/pkg/etc/cron.daily/faxspool-cleaner.sh || exit 1
44
45#make main package
46syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
47
48
49
Note: See TracBrowser for help on using the repository browser.