source: npl/phone/sipp/sipp.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.7 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13#DEP:libpcap
14#DEP:libnet
15#DEP:openssl
16#DEP:ncurses
17
18#Loose build-dependencies
19#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
20#(not recommended)
21##NEED:doxygen
22
23#######Essential package info.
24#Change these if autodetection fails.
25
26#Name of the Syn-3 package that we are going to create
27NAME=`basename $0|sed 's/.SlackBuild//'`
28
29#Archive of the sourcefiles to unpack
30SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
31
32#Version of the sourcefiles
33VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
34
35#Architecture that the created binaries run on.
36#Use noarch for scripts.
37ARCH=`uname -m`
38
39#from this point on, exit on errors:
40set -e
41
42########Build and create the pacakge.
43#Uncomment the stuff that you dont want or need
44
45#Unpack source
46#(uncomment if not needed)
47syn3_unpack $SRC_ARC
48
49#Directory where the sourcefiles are unpacked.
50#(you might have to adjust this if autodetection fails)
51SRC_DIR=`ls -c|head -1`
52
53#apply patches
54patch -p1 -d $SRC_DIR < sipp_port_fix.patch || exit 1
55
56pushd $SRC_DIR
57
58#AUTOMAKE: Configure
59#Some usefull stuff you sometimes need to set:
60#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
61#export LD_LIBRARY_PATH=/usr/lib/mysql
62#export VPATH=$LD_LIBRARY_PATH
63MAKE_OPTS=""
64#./configure --prefix=/usr  || exit 1
65
66#AUTOMAKE: Compile
67make $MAKE_OPTS pcapplay_ossl >/dev/null || exit 1
68
69#AUTOMAKE: Test (optional)
70#if grep ^check: Makefile; then
71#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
72#       make $MAKE_OPTS check || exit 1
73#elif grep ^test: Makefile; then
74#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
75#       make $MAKE_OPTS test || exit 1
76#fi
77
78#AUTOMAKE: Install
79mkdir -p /tmp/pkg/usr/bin &>/dev/null || exit 1
80#make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1
81cp sipp /tmp/pkg/usr/bin || exit 1
82popd
83
84#strip bins and other stuff
85syn3_strip /tmp/pkg || exit 1
86
87#move development stuff and create seperate development package
88syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
89syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
90
91#make main package
92syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
Note: See TracBrowser for help on using the repository browser.