[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | #DEP:libtiff |
---|
| 7 | #DEP:libjpeg |
---|
| 8 | #Strict build-dependencies |
---|
| 9 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
| 10 | #(this is recommended for most dependencys) |
---|
| 11 | ##DEP:linux |
---|
| 12 | ##DEP:linux_src |
---|
| 13 | ##DEP:openldap |
---|
| 14 | |
---|
| 15 | #Loose build-dependencies |
---|
| 16 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
| 17 | #(not recommended) |
---|
| 18 | ##NEED:doxygen |
---|
| 19 | |
---|
| 20 | #######Essential package info. |
---|
| 21 | #Change these if autodetection fails. |
---|
| 22 | |
---|
| 23 | #Name of the Syn-3 package that we are going to create |
---|
| 24 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 25 | |
---|
| 26 | #Archive of the sourcefiles to unpack |
---|
| 27 | SRC_ARC=`ls *.tar.gz 2>/dev/null` |
---|
| 28 | |
---|
| 29 | #Version of the sourcefiles |
---|
| 30 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
| 31 | |
---|
| 32 | #Architecture that the created binaries run on. |
---|
| 33 | #Use noarch for scripts. |
---|
| 34 | ARCH=`uname -m` |
---|
| 35 | |
---|
| 36 | #from this point on, exit on errors: |
---|
| 37 | set -e |
---|
| 38 | |
---|
| 39 | ########Build and create the pacakge. |
---|
| 40 | #Uncomment the stuff that you dont want or need |
---|
| 41 | |
---|
| 42 | #Unpack source |
---|
| 43 | #(uncomment if not needed) |
---|
| 44 | syn3_unpack $SRC_ARC |
---|
| 45 | |
---|
| 46 | #Directory where the sourcefiles are unpacked. |
---|
| 47 | #(you might have to adjust this if autodetection fails) |
---|
| 48 | SRC_DIR=`ls -c|head -1` |
---|
| 49 | |
---|
| 50 | #apply patches |
---|
| 51 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 52 | |
---|
| 53 | pushd $SRC_DIR |
---|
| 54 | |
---|
| 55 | #AUTOMAKE: Configure |
---|
| 56 | #Some usefull stuff you sometimes need to set: |
---|
| 57 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
| 58 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
| 59 | #export VPATH=$LD_LIBRARY_PATH |
---|
| 60 | #export CFLAGS="-fgnu89-inline" |
---|
| 61 | MAKE_OPTS="" |
---|
| 62 | ./configure --prefix=/usr || exit 1 |
---|
| 63 | |
---|
| 64 | #AUTOMAKE: Compile |
---|
| 65 | |
---|
| 66 | make $MAKE_OPTS || exit 1 |
---|
| 67 | |
---|
| 68 | #AUTOMAKE: Test (optional) |
---|
| 69 | if grep ^test: Makefile; then |
---|
| 70 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 71 | make $MAKE_OPTS test || exit 1 |
---|
| 72 | elif grep ^check: Makefile; then |
---|
| 73 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 74 | make $MAKE_OPTS check || exit 1 |
---|
| 75 | fi |
---|
| 76 | |
---|
| 77 | #AUTOMAKE: Install |
---|
| 78 | mkdir -p /tmp/pkg &>/dev/null |
---|
| 79 | make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1 |
---|
| 80 | popd |
---|
| 81 | |
---|
| 82 | #strip bins and other stuff |
---|
| 83 | syn3_strip /tmp/pkg || exit 1 |
---|
| 84 | |
---|
| 85 | #move development stuff and create seperate development package |
---|
| 86 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 87 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 88 | |
---|
| 89 | #make main package |
---|
| 90 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 91 | |
---|
| 92 | |
---|
| 93 | |
---|