source: npl/python/python_Mako/python_Mako.SlackBuild @ 55828be

perl-5.22
Last change on this file since 55828be was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.4 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7#DEP:python_setuptools
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15if ! echo $NAME | grep "^python_"; then
16        echo "python modules should have a packagename that starts with python_ !"
17        exit 1
18fi
19
20#Archive of the sourcefiles to unpack
21SRC_ARC=`ls *.tar.*`
22
23#Version of the sourcefiles
24VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
25
26#Directory of the sourcefiles to build (after optional unpacking)
27SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
28
29#Architecture that the created binaries run on.
30#Use noarch for scripts.
31ARCH=`uname -m`
32
33
34########Build and create the pacakge.
35#Uncomment the stuff that you dont want or need
36
37#Unpack source
38#(uncomment if not needed)
39syn3_unpack $SRC_ARC || exit 1
40
41#apply patches
42#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
43
44pushd $SRC_DIR || exit 1
45python setup.py install --root=/tmp/pkg || exit 1
46popd
47
48#strip bins and other stuff
49syn3_strip /tmp/pkg || exit 1
50
51#move development stuff and create seperate development package
52syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
53syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
54
55#make main package
56syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
57
58
Note: See TracBrowser for help on using the repository browser.