source: npl/python/python_bsddb/python_bsddb.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.4 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7#DEP:python_setuptools
8#DEP:db48
9
10#######Essential package info.
11#Change these if autodetection fails.
12
13#Name of the Syn-3 package that we are going to create
14NAME=`basename $0|sed 's/.SlackBuild//'`
15
16if ! echo $NAME | grep "^python_"; then
17        echo "python modules should have a packagename that starts with python_ !"
18        exit 1
19fi
20
21#Archive of the sourcefiles to unpack
22SRC_ARC=`ls *.tar.*`
23
24#Version of the sourcefiles
25VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
26
27#Directory of the sourcefiles to build (after optional unpacking)
28SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
29
30#Architecture that the created binaries run on.
31#Use noarch for scripts.
32ARCH=`uname -m`
33
34
35########Build and create the pacakge.
36#Uncomment the stuff that you dont want or need
37
38#Unpack source
39#(uncomment if not needed)
40syn3_unpack $SRC_ARC || exit 1
41
42#apply patches
43#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
44
45pushd $SRC_DIR || exit 1
46python setup.py install --root=/tmp/pkg || exit 1
47popd
48
49#strip bins and other stuff
50syn3_strip /tmp/pkg || exit 1
51
52#move development stuff and create seperate development package
53syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
54syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
55
56#make main package
57syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
58
59
Note: See TracBrowser for help on using the repository browser.