[128fde4] | 1 | #!/bin/bash |
---|
| 2 | # Generic python build script. (C)DatuX |
---|
| 3 | # Put in in a builddirectory with a python tarfile that contains a setup.py. |
---|
| 4 | # Please python_modulename for python modules. |
---|
| 5 | |
---|
| 6 | #DEP:python |
---|
| 7 | #DEP:python_setuptools |
---|
| 8 | |
---|
| 9 | #######Essential package info. |
---|
| 10 | #Change these if autodetection fails. |
---|
| 11 | |
---|
| 12 | #Name of the Syn-3 package that we are going to create |
---|
| 13 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 14 | |
---|
| 15 | if ! echo $NAME | grep "^python_"; then |
---|
| 16 | echo "python modules should have a packagename that starts with python_ !" |
---|
| 17 | exit 1 |
---|
| 18 | fi |
---|
| 19 | |
---|
| 20 | #Archive of the sourcefiles to unpack |
---|
| 21 | SRC_ARC=`ls *.tar.*` |
---|
| 22 | |
---|
| 23 | #Version of the sourcefiles |
---|
| 24 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'` |
---|
| 25 | |
---|
| 26 | #Directory of the sourcefiles to build (after optional unpacking) |
---|
| 27 | SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'` |
---|
| 28 | |
---|
| 29 | #Architecture that the created binaries run on. |
---|
| 30 | #Use noarch for scripts. |
---|
| 31 | ARCH=`uname -m` |
---|
| 32 | |
---|
| 33 | |
---|
| 34 | ########Build and create the pacakge. |
---|
| 35 | #Uncomment the stuff that you dont want or need |
---|
| 36 | |
---|
| 37 | #Unpack source |
---|
| 38 | #(uncomment if not needed) |
---|
| 39 | syn3_unpack $SRC_ARC || exit 1 |
---|
| 40 | |
---|
| 41 | #apply patches |
---|
| 42 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 43 | |
---|
| 44 | pushd $SRC_DIR || exit 1 |
---|
| 45 | python setup.py install --root=/tmp/pkg || exit 1 |
---|
| 46 | popd |
---|
| 47 | |
---|
| 48 | #strip bins and other stuff |
---|
| 49 | syn3_strip /tmp/pkg || exit 1 |
---|
| 50 | |
---|
| 51 | #move development stuff and create seperate development package |
---|
| 52 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 53 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 54 | |
---|
| 55 | #make main package |
---|
| 56 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 57 | |
---|
| 58 | |
---|