source: npl/python/python_pycurl/python_pycurl.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.5 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7#DEP:python_setuptools
8#DEP:curl
9#DEP:openssl
10#DEP:zlib
11
12#######Essential package info.
13#Change these if autodetection fails.
14
15#Name of the Syn-3 package that we are going to create
16NAME=`basename $0|sed 's/.SlackBuild//'`
17
18if ! echo $NAME | grep "^python_"; then
19        echo "python modules should have a packagename that starts with python_ !"
20        exit 1
21fi
22
23#Archive of the sourcefiles to unpack
24SRC_ARC=`ls *.tar.*`
25
26#Version of the sourcefiles
27VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
28
29#Directory of the sourcefiles to build (after optional unpacking)
30SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
31
32#Architecture that the created binaries run on.
33#Use noarch for scripts.
34ARCH=`uname -m`
35
36
37########Build and create the pacakge.
38#Uncomment the stuff that you dont want or need
39
40#Unpack source
41#(uncomment if not needed)
42syn3_unpack $SRC_ARC || exit 1
43
44#apply patches
45#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
46
47pushd $SRC_DIR || exit 1
48python setup.py install --root=/tmp/pkg || exit 1
49popd
50
51#strip bins and other stuff
52syn3_strip /tmp/pkg || exit 1
53
54#move development stuff and create seperate development package
55syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
56syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
57
58#make main package
59syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
60
61
Note: See TracBrowser for help on using the repository browser.