source: npl/python/python_pygobject/python_pygobject.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:python
8#DEP:glib2
9##DEP:gobject_introspection
10#DEP:python_pycairo
11
12#######Essential package info.
13#Change these if autodetection fails.
14
15#Name of the Syn-3 package that we are going to create
16NAME=`basename $0|sed 's/.SlackBuild//'`
17
18#Archive of the sourcefiles to unpack
19SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
20
21#Version of the sourcefiles
22VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
23
24#Architecture that the created binaries run on.
25#Use noarch for scripts.
26ARCH=`uname -m`
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC || exit 1
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41
42export CFLAGS="-fgnu89-inline"
43
44#AUTOMAKE: Configure
45pushd $SRC_DIR || exit 1
46./configure --prefix=/usr --disable-introspection || exit 1
47
48#AUTOMAKE: Compile
49MAKE_OPTS=""
50make $MAKE_OPTS >/dev/null || exit 1
51
52#AUTOMAKE: Install
53mkdir -p /tmp/pkg &>/dev/null
54make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1
55popd
56
57#strip bins and other stuff
58syn3_strip /tmp/pkg || exit 1
59
60#move development stuff and create seperate development package
61syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
62syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
63
64#make main package
65syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
66
67
Note: See TracBrowser for help on using the repository browser.