[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | # Generic python build script. (C)DatuX |
---|
| 3 | # Put in in a builddirectory with a python tarfile that contains a setup.py. |
---|
| 4 | # Please python_modulename for python modules. |
---|
| 5 | |
---|
| 6 | #DEP:python |
---|
| 7 | #DEP:python_setuptools |
---|
| 8 | ##DEP:python_pyOpenSSL |
---|
| 9 | |
---|
| 10 | #######Essential package info. |
---|
| 11 | #Change these if autodetection fails. |
---|
| 12 | |
---|
| 13 | #Name of the Syn-3 package that we are going to create |
---|
| 14 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 15 | |
---|
| 16 | if ! echo $NAME | grep "^python_"; then |
---|
| 17 | echo "python modules should have a packagename that starts with python_ !" |
---|
| 18 | exit 1 |
---|
| 19 | fi |
---|
| 20 | |
---|
| 21 | #Archive of the sourcefiles to unpack |
---|
| 22 | SRC_ARC=`ls *.tar.*` |
---|
| 23 | |
---|
| 24 | #Version of the sourcefiles |
---|
| 25 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'` |
---|
| 26 | |
---|
| 27 | #Directory of the sourcefiles to build (after optional unpacking) |
---|
| 28 | SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'` |
---|
| 29 | |
---|
| 30 | #Architecture that the created binaries run on. |
---|
| 31 | #Use noarch for scripts. |
---|
| 32 | ARCH=`uname -m` |
---|
| 33 | |
---|
| 34 | |
---|
| 35 | ########Build and create the pacakge. |
---|
| 36 | #Uncomment the stuff that you dont want or need |
---|
| 37 | |
---|
| 38 | #Unpack source |
---|
| 39 | #(uncomment if not needed) |
---|
| 40 | syn3_unpack $SRC_ARC || exit 1 |
---|
| 41 | |
---|
| 42 | #apply patches |
---|
| 43 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 44 | |
---|
| 45 | pushd $SRC_DIR || exit 1 |
---|
| 46 | python setup.py install --root=/tmp/pkg || exit 1 |
---|
| 47 | popd |
---|
| 48 | |
---|
| 49 | #strip bins and other stuff |
---|
| 50 | syn3_strip /tmp/pkg || exit 1 |
---|
| 51 | |
---|
| 52 | #move development stuff and create seperate development package |
---|
| 53 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 54 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 55 | |
---|
| 56 | #make main package |
---|
| 57 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 58 | |
---|
| 59 | |
---|