source: npl/python/setuptools/python_setuptools.SlackBuild @ 3daa803

Last change on this file since 3daa803 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.2 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4
5#DEP:python
6
7#######Essential package info.
8#Change these if autodetection fails.
9
10#Name of the Syn-3 package that we are going to create
11NAME=`basename $0|sed 's/.SlackBuild//'`
12
13#Archive of the sourcefiles to unpack
14SRC_ARC=`ls *.tar.*`
15
16#Version of the sourcefiles
17VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
18
19#Directory of the sourcefiles to build (after optional unpacking)
20SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
21
22#Architecture that the created binaries run on.
23#Use noarch for scripts.
24ARCH=`uname -m`
25
26
27########Build and create the pacakge.
28#Uncomment the stuff that you dont want or need
29
30#Unpack source
31#(uncomment if not needed)
32syn3_unpack $SRC_ARC || exit 1
33
34#apply patches
35#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
36
37pushd $SRC_DIR || exit 1
38python setup.py install --root=/tmp/pkg || exit 1
39popd
40
41#strip bins and other stuff
42syn3_strip /tmp/pkg || exit 1
43
44#move development stuff and create seperate development package
45syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
46syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
47
48#make main package
49syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
50
51
Note: See TracBrowser for help on using the repository browser.