[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | |
---|
| 7 | #Strict build-dependencies |
---|
| 8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
| 9 | #(this is recommended for most dependencys) |
---|
| 10 | ##DEP:linux |
---|
| 11 | ##DEP:linux_src |
---|
| 12 | ##DEP:openldap |
---|
| 13 | |
---|
| 14 | #Loose build-dependencies |
---|
| 15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
| 16 | #(not recommended) |
---|
| 17 | ##NEED:doxygen |
---|
| 18 | |
---|
| 19 | #######Essential package info. |
---|
| 20 | #Change these if autodetection fails. |
---|
| 21 | |
---|
| 22 | #Name of the Syn-3 package that we are going to create |
---|
| 23 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 24 | |
---|
| 25 | #Archive of the sourcefiles to unpack |
---|
| 26 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
| 27 | |
---|
| 28 | #Version of the sourcefiles |
---|
| 29 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
| 30 | |
---|
| 31 | #Architecture that the created binaries run on. |
---|
| 32 | #Use noarch for scripts. |
---|
| 33 | ARCH=`uname -m` |
---|
| 34 | |
---|
| 35 | #from this point on, exit on errors: |
---|
| 36 | set -e |
---|
| 37 | |
---|
| 38 | ########Build and create the pacakge. |
---|
| 39 | #Uncomment the stuff that you dont want or need |
---|
| 40 | |
---|
| 41 | #Unpack source |
---|
| 42 | #(uncomment if not needed) |
---|
| 43 | syn3_unpack $SRC_ARC |
---|
| 44 | |
---|
| 45 | #Directory where the sourcefiles are unpacked. |
---|
| 46 | #(you might have to adjust this if autodetection fails) |
---|
| 47 | SRC_DIR=`ls -c|head -1` |
---|
| 48 | |
---|
| 49 | #apply patches |
---|
| 50 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 51 | |
---|
| 52 | pushd $SRC_DIR |
---|
| 53 | |
---|
| 54 | #AUTOMAKE: Configure |
---|
| 55 | #Some usefull stuff you sometimes need to set: |
---|
| 56 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
| 57 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
| 58 | #export VPATH=$LD_LIBRARY_PATH |
---|
| 59 | MAKE_OPTS="" |
---|
| 60 | |
---|
| 61 | zcat /tmp/build/biff+comsat-0.17.diff.gz | patch -p1 --verbose || exit |
---|
| 62 | zcat /tmp/build/biff+comsat.offset.diff.gz | patch -p1 --verbose || exit |
---|
| 63 | zcat /tmp/build/biff+comsat.badutmp.diff.gz | patch -p1 --verbose || exit |
---|
| 64 | |
---|
| 65 | ./configure --prefix=/usr || exit 1 |
---|
| 66 | |
---|
| 67 | #AUTOMAKE: Compile |
---|
| 68 | make $MAKE_OPTS >/dev/null || exit 1 |
---|
| 69 | |
---|
| 70 | #AUTOMAKE: Install |
---|
| 71 | mkdir -p /tmp/pkg &>/dev/null |
---|
| 72 | #make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1 |
---|
| 73 | PKG=/tmp/pkg |
---|
| 74 | |
---|
| 75 | cd biff || exit 1 |
---|
| 76 | strip biff |
---|
| 77 | mkdir -p $PKG/usr/bin |
---|
| 78 | cat biff > $PKG/usr/bin/biff |
---|
| 79 | chmod 755 $PKG/usr/bin/biff |
---|
| 80 | mkdir -p $PKG/usr/man/man{1,8} |
---|
| 81 | cat biff.1 | gzip -9c > $PKG/usr/man/man1/biff.1.gz |
---|
| 82 | cd ../comsat |
---|
| 83 | strip comsat |
---|
| 84 | mkdir -p $PKG/usr/sbin |
---|
| 85 | cat comsat > $PKG/usr/sbin/in.comsat |
---|
| 86 | chmod 755 $PKG/usr/sbin/in.comsat |
---|
| 87 | cat comsat.8 | gzip -9c > $PKG/usr/man/man8/in.comsat.8.gz |
---|
| 88 | cd .. |
---|
| 89 | mkdir -p $PKG/usr/doc/biff+comsat-0.17 |
---|
| 90 | cp -a README $PKG/usr/doc/biff+comsat-0.17 |
---|
| 91 | chown root:root $PKG/usr/doc/biff+comsat-0.17/* |
---|
| 92 | chmod 644 $PKG/usr/doc/biff+comsat-0.17/* |
---|
| 93 | |
---|
| 94 | |
---|
| 95 | |
---|
| 96 | #strip bins and other stuff |
---|
| 97 | syn3_strip /tmp/pkg || exit 1 |
---|
| 98 | |
---|
| 99 | #move development stuff and create seperate development package |
---|
| 100 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 101 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 102 | |
---|
| 103 | popd |
---|
| 104 | |
---|
| 105 | #make main package |
---|
| 106 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 107 | |
---|
| 108 | |
---|
| 109 | |
---|