source: npl/system/bsd-finger/bsd_finger.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#######Essential package info.
20#Change these if autodetection fails.
21
22#Name of the Syn-3 package that we are going to create
23NAME=`basename $0|sed 's/.SlackBuild//'`
24
25#Archive of the sourcefiles to unpack
26SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
27
28#Version of the sourcefiles
29VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
30
31#Architecture that the created binaries run on.
32#Use noarch for scripts.
33ARCH=`uname -m`
34
35#from this point on, exit on errors:
36set -e
37
38########Build and create the pacakge.
39#Uncomment the stuff that you dont want or need
40
41#Unpack source
42#(uncomment if not needed)
43syn3_unpack $SRC_ARC
44
45#Directory where the sourcefiles are unpacked.
46#(you might have to adjust this if autodetection fails)
47SRC_DIR=`ls -c|head -1`
48
49#apply patches
50#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
51
52pushd $SRC_DIR
53
54#AUTOMAKE: Configure
55#Some usefull stuff you sometimes need to set:
56#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
57#export LD_LIBRARY_PATH=/usr/lib/mysql
58#export VPATH=$LD_LIBRARY_PATH
59MAKE_OPTS=""
60zcat /tmp/build/bsd-finger-0.17.diff.gz | patch -p1 || exit
61./configure --prefix=/usr  || exit 1
62
63#AUTOMAKE: Compile
64make $MAKE_OPTS >/dev/null || exit 1
65
66#AUTOMAKE: Install
67mkdir -p /tmp/pkg &>/dev/null
68#make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1
69PKG=/tmp/pkg
70
71cd finger
72strip finger
73mkdir -p $PKG/usr/bin
74cat finger > $PKG/usr/bin/finger
75chmod 755 $PKG/usr/bin/finger
76mkdir -p $PKG/usr/man/man{1,8}
77cat finger.1 | gzip -9c > $PKG/usr/man/man1/finger.1.gz
78cd ../fingerd
79strip fingerd
80mkdir -p $PKG/usr/sbin
81cat fingerd > $PKG/usr/sbin/in.fingerd
82chmod 755 $PKG/usr/sbin/in.fingerd
83cat fingerd.8 | gzip -9c > $PKG/usr/man/man8/in.fingerd.8.gz
84cd ..
85mkdir -p $PKG/usr/doc/bsd-finger-0.17
86cp -a README $PKG/usr/doc/bsd-finger-0.17
87chown root:root $PKG/usr/doc/bsd-finger-0.17/*
88chmod 644 $PKG/usr/doc/bsd-finger-0.17/*
89
90#strip bins and other stuff
91syn3_strip /tmp/pkg || exit 1
92
93#move development stuff and create seperate development package
94syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
95syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
96
97popd
98
99#make main package
100syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
101
102
103
Note: See TracBrowser for help on using the repository browser.