Last change
on this file since 08cf024 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
778 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/sh |
---|
| 2 | #DEP:ncurses |
---|
| 3 | |
---|
| 4 | |
---|
| 5 | # Set initial variables: |
---|
| 6 | CWD=`pwd` |
---|
| 7 | if [ "$TMP" = "" ]; then |
---|
| 8 | TMP=/tmp |
---|
| 9 | fi |
---|
| 10 | NAME=busybox |
---|
| 11 | VERSION=1.23.2 |
---|
| 12 | TARVER=1.23.2 |
---|
| 13 | ARCH=`arch` |
---|
| 14 | |
---|
| 15 | # Compile |
---|
| 16 | mkdir -p $PKG |
---|
| 17 | |
---|
| 18 | tar -xjf $NAME-$TARVER.tar.bz2 || exit 1 |
---|
| 19 | |
---|
| 20 | cd $NAME-$TARVER |
---|
| 21 | |
---|
| 22 | #cd util-linux |
---|
| 23 | #patch -p1 switch_root.c<$CWD/nocheck.patch || exit 1 |
---|
| 24 | #cd .. |
---|
| 25 | |
---|
| 26 | #export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html |
---|
| 27 | |
---|
| 28 | make clean || exit 1 |
---|
| 29 | cp ../config .config || exit 1 |
---|
| 30 | make oldconfig || exit 1 |
---|
| 31 | make -j1 || exit 1 |
---|
| 32 | make install || exit 1 |
---|
| 33 | |
---|
| 34 | |
---|
| 35 | # Create the package: |
---|
| 36 | cd _install || exit 1 |
---|
| 37 | |
---|
| 38 | #makepkg -l y -c n $TMP/logrotate-$VERSION-$ARCH-$BUILD.tgz |
---|
| 39 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 40 | echo $VERSION > $CWD/$NAME.version && |
---|
| 41 | arch > $CWD/$NAME.arch |
---|
| 42 | |
---|
| 43 | |
---|
| 44 | |
---|
Note: See
TracBrowser
for help on using the repository browser.