source: npl/system/busybox/busybox.SlackBuild @ 08cf024

Last change on this file since 08cf024 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 778 bytes
RevLine 
[c5c522c]1#!/bin/sh
2#DEP:ncurses
3
4
5# Set initial variables:
6CWD=`pwd`
7if [ "$TMP" = "" ]; then
8  TMP=/tmp
9fi
10NAME=busybox
11VERSION=1.23.2
12TARVER=1.23.2
13ARCH=`arch`
14
15# Compile
16mkdir -p $PKG
17
18tar -xjf $NAME-$TARVER.tar.bz2 || exit 1
19
20cd $NAME-$TARVER
21
22#cd util-linux
23#patch -p1 switch_root.c<$CWD/nocheck.patch || exit 1
24#cd ..
25
26#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
27
28make  clean || exit 1
29cp ../config .config || exit 1
30make  oldconfig || exit 1
31make -j1 || exit 1
32make install || exit 1
33
34
35# Create the package:
36cd _install || exit 1
37
38#makepkg -l y -c n $TMP/logrotate-$VERSION-$ARCH-$BUILD.tgz
39makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
40echo $VERSION > $CWD/$NAME.version &&
41arch > $CWD/$NAME.arch
42
43
44
Note: See TracBrowser for help on using the repository browser.