source: npl/system/ethtool/ethtool.SlackBuild.orig

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.8 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2011  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=ethtool
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38CWD=$(pwd)
39TMP=${TMP:-/tmp}
40PKG=$TMP/package-ethtool
41
42if [ "$ARCH" = "i586" ]; then
43  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "s390" ]; then
46  SLKCFLAGS="-O2"
47  LIBDIRSUFFIX=""
48elif [ "$ARCH" = "x86_64" ]; then
49  SLKCFLAGS="-O2 -fPIC"
50  LIBDIRSUFFIX="64"
51else
52  SLKCFLAGS="-O2"
53  LIBDIRSUFFIX=""
54fi
55
56rm -rf $PKG
57mkdir -p $TMP $PKG
58cd $TMP
59rm -rf ethtool-$VERSION
60tar xvf $CWD/ethtool-$VERSION.tar.?z* || exit 1
61cd ethtool-$VERSION || exit 1
62chown -R root:root .
63
64CFLAGS="$SLKCFLAGS" \
65./configure \
66  --prefix=/usr \
67  --mandir=/usr/man \
68  --build=$ARCH-slackware-linux
69
70make || exit 1
71make install DESTDIR=$PKG
72
73strip --strip-unneeded $PKG/usr/sbin/ethtool
74gzip -9 $PKG/usr/man/man8/ethtool.8
75
76mkdir -p $PKG/usr/doc/ethtool-$VERSION
77cp -a \
78  AUTHORS COPYING* LICENSE NEWS README* \
79  $PKG/usr/doc/ethtool-$VERSION
80chmod 644 $PKG/usr/doc/ethtool-$VERSION/*
81
82# If there's a ChangeLog, installing at least part of the recent history
83# is useful, but don't let it get totally out of control:
84if [ -r ChangeLog ]; then
85  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
86  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
87  touch -r ChangeLog $DOCSDIR/ChangeLog
88fi
89
90# Finish up the package:
91mkdir -p $PKG/install
92cat $CWD/slack-desc > $PKG/install/slack-desc
93
94# Build the package:
95cd $PKG
96/sbin/makepkg -l y -c n $TMP/ethtool-$VERSION-$ARCH-$BUILD.txz
97
Note: See TracBrowser for help on using the repository browser.