source: npl/system/glusterfs/glusterfs.SlackBuild @ 7c410f9

Last change on this file since 7c410f9 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.8 KB
RevLine 
[c5c522c]1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13#DEP:fuse
14
15#Loose build-dependencies
16#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
17#(not recommended)
18##NEED:doxygen
19
20#######Essential package info.
21#Change these if autodetection fails.
22
23#Name of the Syn-3 package that we are going to create
24NAME=`basename $0|sed 's/.SlackBuild//'`
25
26#Archive of the sourcefiles to unpack
27SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
28
29#Version of the sourcefiles
30VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
31
32#Architecture that the created binaries run on.
33#Use noarch for scripts.
34ARCH=`uname -m`
35
36#from this point on, exit on errors:
37set -e
38
39########Build and create the pacakge.
40#Uncomment the stuff that you dont want or need
41
42#Unpack source
43#(uncomment if not needed)
44syn3_unpack $SRC_ARC
45
46#Directory where the sourcefiles are unpacked.
47#(you might have to adjust this if autodetection fails)
48SRC_DIR=`ls -c|head -1`
49
50#apply patches
51#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
52
53pushd $SRC_DIR
54
55#AUTOMAKE: Configure
56#Some usefull stuff you sometimes need to set:
57#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
58#export LD_LIBRARY_PATH=/usr/lib/mysql
59#export VPATH=$LD_LIBRARY_PATH
60MAKE_OPTS=""
61./configure --prefix=/usr --sysconfdir=/etc --with-extras --enable-fuse-client || exit 1
62
63#AUTOMAKE: Compile
64make $MAKE_OPTS || exit 1
65
66#AUTOMAKE: Test (optional)
67if grep ^test: Makefile; then
68        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
69        make $MAKE_OPTS test || exit 1
70elif grep ^check: Makefile; then
71        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
72        make $MAKE_OPTS check || exit 1
73fi
74
75#AUTOMAKE: Install
76mkdir -p /tmp/pkg &>/dev/null
77make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
78popd
79
80cp $SRC_DIR/extras/glusterfs-volgen.py /tmp/pkg/usr/sbin/glusterfs-volgen
81chmod +x /tmp/pkg/usr/sbin/glusterfs-volgen
82
83#strip bins and other stuff
84syn3_strip /tmp/pkg || exit 1
85
86#move development stuff and create seperate development package
87syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
88syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
89
90#make main package
91syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
92
93
94
Note: See TracBrowser for help on using the repository browser.