source: npl/system/gnupg/gnupg.SlackBuild @ aafe99e

perl-5.22
Last change on this file since aafe99e was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.7 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6#DEP:bzip2
7#DEP:zlib
8
9
10
11#######Essential package info.
12#Change these if autodetection fails.
13
14#Name of the Syn-3 package that we are going to create
15NAME=`basename $0|sed 's/.SlackBuild//'`
16
17#Archive of the sourcefiles to unpack
18SRC_ARC=`ls *.tar.*`
19
20#Version of the sourcefiles
21VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
22
23#Directory of the sourcefiles to build (after optional unpacking)
24SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
25
26#Architecture that the created binaries run on.
27#Use noarch for scripts.
28ARCH=`uname -m`
29
30
31########Build and create the pacakge.
32#Uncomment the stuff that you dont want or need
33
34#Unpack source
35#(uncomment if not needed)
36syn3_unpack $SRC_ARC || exit 1
37
38#apply patches
39#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
40
41#build and install sourcefiles
42#./configure optiones:
43export CONFIGURE_OPTS=""
44#options for all make commands:
45export MAKE_OPTS=""
46#skip testing:
47#export NOTEST=1
48#extra optiones for the make install command, use with INSTALL_BASE for example:
49export INSTALL_OPTS=""
50syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
51
52#strip bins and other stuff
53syn3_strip /tmp/pkg || exit 1
54
55#move development stuff and create seperate development package
56syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
57syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
58
59#make main package
60syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
61
62
Note: See TracBrowser for help on using the repository browser.