source: npl/system/grub/grub.SlackBuild @ 4933918

perl-5.22
Last change on this file since 4933918 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#DEP:lzo
3#DEP:ncurses
4
5NAME=grub
6VER=0.97
7CWD=`pwd`
8PKGTMP=/tmp/pkgtmp
9
10mkdir -p $PKGTMP &>/dev/null
11
12tar -xzf $NAME-$VER.tar.gz || exit 1
13
14#gentoo patches, grub development loopt achter ivm grub2
15#tar -xjf $NAME-$VER-patches-1.4.tar.bz2 || exit 1
16#tar -xjf $NAME-$VER-patches-1.2.tar.bz2 || exit 1
17tar -xjf $NAME-$VER-patches-1.9.tar.bz2 || exit 1
18rm patch/*netboot*
19
20cd $NAME-$VER
21
22#filter patches we DONT want:
23rm ../patch/850_all_grub-0.97_ext4.patch || exit 1
24
25#apply patches
26for PATCH in ../patch/*.patch; do
27        echo "patch $PATCH"
28        if ! patch -p1 < $PATCH; then
29            echo "OOPS - Trying to patch again, with -p0 this time..."
30            patch -p0 < $PATCH || exit 1
31        fi
32done
33
34#fix for newer automakes
35fgrep -rlZ pkglib_DATA --include Makefile.am . | xargs -0 sed -i 's/pkglib_DATA/pkgdata_DATA/g'
36
37export CFLAGS="-fgnu89-inline"
38
39#deze ac dingen zijn nodig, omdat we zojuist een patch gedaan hebben op configure.ac:
40aclocal || exit 1
41autoheader || exit 1
42automake -a|| exit 1
43autoconf || exit 1
44./configure --prefix=/usr --disable-auto-linux-mem-opt || exit 1
45make || exit 1
46make  DESTDIR=$PKGTMP install || exit 1
47
48#somehow this moved with newer buildtools
49mkdir -p $PKGTMP/usr/lib/grub/i386-pc/
50mv $PKGTMP/usr/share/grub/* $PKGTMP/usr/lib/grub/i386-pc/ || exit 1
51rmdir $PKGTMP/usr/share/grub
52
53#mkdir -p $PKGTMP/etc/postinst.d || exit 1
54#cp post.grub $PKGTMP/etc/postinst.d || exit 1
55mkdir -p $PKGTMP/boot/grub || exit 1
56
57cp -a $CWD/*.lst $PKGTMP/boot/grub || exit 1
58ln -s menu-B.lst $PKGTMP/boot/grub/menu.lst || exit 1
59
60mkdir $PKGTMP/sbin
61cp $CWD/syn3-install-grub $PKGTMP/sbin || exit 1
62chmod +x $PKGTMP/sbin/syn3-install-grub || exit 1
63
64mkdir -p $PKGTMP/etc/postinst.d
65cp $CWD/post.grub $PKGTMP/etc/postinst.d || exit 1
66chmod +x $PKGTMP/etc/postinst.d/post.grub || exit 1
67
68cp $CWD/syn3splash.xpm.gz $PKGTMP/boot/grub || exit 1
69
70cd "$PKGTMP" || exit 1
71makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
72echo $VER > $CWD/$NAME.version &&
73arch > $CWD/$NAME.arch
74
Note: See TracBrowser for help on using the repository browser.