source: npl/system/hwdata/hwdata.SlackBuild @ 128fde4

gcc484perl-5.22
Last change on this file since 128fde4 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 523 bytes
RevLine 
[c5c522c]1#!/bin/bash
2
3# Set initial variables:
4CWD=`pwd`
5if [ "$TMP" = "" ]; then
6  TMP=/tmp
7fi
8PKG=$TMP/pkg
9NAME=hwdata
10VERSION=0.172
11ARCH=`arch`
12
13mkdir -p $PKG
14
15tar -xzf $NAME-$VERSION.tar.gz || exit 1
16
17cd $NAME-$VERSION || exit 1
18#patch hwsetup.c <../hwsetup.patch || exit 1
19
20make || exit 1
21make DESTDIR=$PKG install || exit 1
22
23# Create the package:
24cd $PKG
25#makepkg -l y -c n $TMP/logrotate-$VERSION-$ARCH-$BUILD.tgz
26makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
27echo $VERSION > $CWD/$NAME.version &&
28arch > $CWD/$NAME.arch
29
Note: See TracBrowser for help on using the repository browser.