Last change
on this file since 720681d was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
523 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | |
---|
3 | # Set initial variables: |
---|
4 | CWD=`pwd` |
---|
5 | if [ "$TMP" = "" ]; then |
---|
6 | TMP=/tmp |
---|
7 | fi |
---|
8 | PKG=$TMP/pkg |
---|
9 | NAME=hwdata |
---|
10 | VERSION=0.172 |
---|
11 | ARCH=`arch` |
---|
12 | |
---|
13 | mkdir -p $PKG |
---|
14 | |
---|
15 | tar -xzf $NAME-$VERSION.tar.gz || exit 1 |
---|
16 | |
---|
17 | cd $NAME-$VERSION || exit 1 |
---|
18 | #patch hwsetup.c <../hwsetup.patch || exit 1 |
---|
19 | |
---|
20 | make || exit 1 |
---|
21 | make DESTDIR=$PKG install || exit 1 |
---|
22 | |
---|
23 | # Create the package: |
---|
24 | cd $PKG |
---|
25 | #makepkg -l y -c n $TMP/logrotate-$VERSION-$ARCH-$BUILD.tgz |
---|
26 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
27 | echo $VERSION > $CWD/$NAME.version && |
---|
28 | arch > $CWD/$NAME.arch |
---|
29 | |
---|
Note: See
TracBrowser
for help on using the repository browser.