1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #Strict build-dependencies |
---|
8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
9 | #(this is recommended for most dependencys) |
---|
10 | ##DEP:linux |
---|
11 | ##DEP:linux_src |
---|
12 | ##DEP:openldap |
---|
13 | |
---|
14 | #Loose build-dependencies |
---|
15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
16 | #(not recommended) |
---|
17 | ##NEED:doxygen |
---|
18 | |
---|
19 | #######Essential package info. |
---|
20 | #Change these if autodetection fails. |
---|
21 | |
---|
22 | #Name of the Syn-3 package that we are going to create |
---|
23 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
24 | |
---|
25 | #Archive of the sourcefiles to unpack |
---|
26 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
27 | |
---|
28 | #Version of the sourcefiles |
---|
29 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
30 | |
---|
31 | #Architecture that the created binaries run on. |
---|
32 | #Use noarch for scripts. |
---|
33 | ARCH=`uname -m` |
---|
34 | |
---|
35 | #from this point on, exit on errors: |
---|
36 | set -e |
---|
37 | |
---|
38 | PKG=/tmp/pkg |
---|
39 | ########Build and create the pacakge. |
---|
40 | #Uncomment the stuff that you dont want or need |
---|
41 | |
---|
42 | #Unpack source |
---|
43 | #(uncomment if not needed) |
---|
44 | syn3_unpack $SRC_ARC |
---|
45 | |
---|
46 | #Directory where the sourcefiles are unpacked. |
---|
47 | #(you might have to adjust this if autodetection fails) |
---|
48 | #SRC_DIR=`ls -c|head -1` |
---|
49 | SRC_DIR=/tmp/build/icmpinfo-1.11 |
---|
50 | #apply patches |
---|
51 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
52 | |
---|
53 | pushd $SRC_DIR |
---|
54 | #AUTOMAKE: Configure |
---|
55 | #Some usefull stuff you sometimes need to set: |
---|
56 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
57 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
58 | #export VPATH=$LD_LIBRARY_PATH |
---|
59 | |
---|
60 | chown -R root:root . |
---|
61 | find . -perm 666 -exec chmod 644 {} \; |
---|
62 | find . -perm 664 -exec chmod 644 {} \; |
---|
63 | find . -perm 600 -exec chmod 644 {} \; |
---|
64 | find . -perm 444 -exec chmod 644 {} \; |
---|
65 | find . -perm 400 -exec chmod 644 {} \; |
---|
66 | find . -perm 440 -exec chmod 644 {} \; |
---|
67 | find . -perm 777 -exec chmod 755 {} \; |
---|
68 | find . -perm 775 -exec chmod 755 {} \; |
---|
69 | find . -perm 511 -exec chmod 755 {} \; |
---|
70 | find . -perm 711 -exec chmod 755 {} \; |
---|
71 | find . -perm 555 -exec chmod 755 {} \; |
---|
72 | |
---|
73 | zcat ../icmpinfo-1.11.diff.gz | patch -p1 --backup || exit 1 |
---|
74 | make || exit 1 |
---|
75 | strip --strip-unneeded icmpinfo || exit 1 |
---|
76 | mkdir -p $PKG/usr/sbin || exit 1 |
---|
77 | cat icmpinfo > $PKG/usr/sbin/icmpinfo || exit 1 |
---|
78 | chmod 755 $PKG/usr/sbin/icmpinfo || exit 1 |
---|
79 | mkdir -p $PKG/usr/man/man1 || exit 1 |
---|
80 | gzip -9c icmpinfo.man > $PKG/usr/man/man1/icmpinfo.1.gz || exit 1 |
---|
81 | mkdir -p $PKG/usr/doc/icmpinfo-1.11 || exit 1 |
---|
82 | cp -a CHANGES README TODO $PKG/usr/doc/icmpinfo-1.11 || exit 1 |
---|
83 | popd |
---|
84 | #make main package |
---|
85 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|