perl-5.22
Last change
on this file since c9ea2dd was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
673 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #NEED:linux_src |
---|
| 3 | |
---|
| 4 | KVER=`uname -r` || exit 1 |
---|
| 5 | NAME=ipsec_tools |
---|
| 6 | VERSION=0.7.2 |
---|
| 7 | CWD=`pwd` |
---|
| 8 | TMP="/tmp" |
---|
| 9 | PKGTMP="$TMP/pkgtmp" |
---|
| 10 | mkdir $PKGTMP &>/dev/null |
---|
| 11 | |
---|
| 12 | tar -xjf ipsec-tools-$VERSION.tar.bz2 || exit 1 |
---|
| 13 | cd ipsec-tools-$VERSION || exit 1 |
---|
| 14 | ./configure --prefix=/usr --disable-ipv6 --enable-natt --enable-dpd --disable-security-context|| exit 1 |
---|
| 15 | #racoon build niet,maar hebben we ook (nog ) niet nodig |
---|
| 16 | #we willen alleen setkey eigenlijk |
---|
| 17 | #cd src/libipsec || exit 1 |
---|
| 18 | #make -j1 || exit 1 |
---|
| 19 | #cd ../setkey || exit 1 |
---|
| 20 | make -j1 || exit 1 |
---|
| 21 | make -j1 DESTDIR=$PKGTMP install|| exit 1 |
---|
| 22 | |
---|
| 23 | cd $PKGTMP |
---|
| 24 | makepkg -l y -c n $CWD/$NAME.pkg |
---|
| 25 | echo $VERSION > $CWD/$NAME.version && |
---|
| 26 | arch > $CWD/$NAME.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.