source: npl/system/iptables/iptables.SlackBuild.orig @ 548499b

perl-5.22
Last change on this file since 548499b was 6a55355, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

upgraded because of better ipv6 support

  • Property mode set to 100755
File size: 3.6 KB
RevLine 
[6a55355]1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2012, 2013  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23VERSION=${VERSION:-$(echo iptables-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
24BUILD=${BUILD:-2}
25
26NUMJOBS=${NUMJOBS:-" -j7 "}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38CWD=$(pwd)
39TMP=${TMP:-/tmp}
40PKG=$TMP/package-iptables
41
42if [ "$ARCH" = "i586" ]; then
43  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "s390" ]; then
46  SLKCFLAGS="-O2"
47  LIBDIRSUFFIX=""
48elif [ "$ARCH" = "x86_64" ]; then
49  SLKCFLAGS="-O2 -fPIC"
50  LIBDIRSUFFIX="64"
51else
52  SLKCFLAGS="-O2"
53  LIBDIRSUFFIX=""
54fi
55
56rm -rf $PKG
57mkdir -p $TMP $PKG
58cd $TMP
59rm -rf iptables-$VERSION
60tar xvf $CWD/iptables-$VERSION.tar.?z* || exit 1
61cd iptables-$VERSION || exit 1
62
63chown -R root:root .
64find . \
65 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
66 -exec chmod 755 {} \; -o \
67 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
68 -exec chmod 644 {} \;
69
70CFLAGS="$SLKCFLAGS" \
71./configure \
72  --prefix=/usr \
73  --libdir=/usr/lib${LIBDIRSUFFIX} \
74  --sysconfdir=/etc \
75  --mandir=/usr/man \
76  --docdir=/usr/doc/iptables-$VERSION \
77  --enable-devel \
78  --enable-libipq \
79  --enable-bpf-compiler \
80  --enable-nfsynproxy \
81  --disable-static \
82  --build=$ARCH-slackware-linux || exit 1
83
84make $NUMJOBS || make || exit 1
85make install DESTDIR=$PKG || exit 1
86
87find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
88  | cut -f 1 -d : | xargs strip --strip-debug 2> /dev/null
89
90# Compress and link manpages, if any:
91if [ -d $PKG/usr/man ]; then
92  ( cd $PKG/usr/man
93    for manpagedir in $(find . -type d -name "man*") ; do
94      ( cd $manpagedir
95        for eachpage in $( find . -type l -maxdepth 1) ; do
96          ln -s $( readlink $eachpage ).gz $eachpage.gz
97          rm $eachpage
98        done
99        gzip -9 *.?
100      )
101    done
102  )
103fi
104
105mkdir -p $PKG/usr/doc/iptables-$VERSION
106cp -a \
107  COPYING* INCOMPATIBILITIES INSTALL \
108  $PKG/usr/doc/iptables-$VERSION
109
110# If there's a ChangeLog, installing at least part of the recent history
111# is useful, but don't let it get totally out of control:
112if [ -r ChangeLog ]; then
113  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
114  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
115  touch -r ChangeLog $DOCSDIR/ChangeLog
116fi
117
118mkdir -p $PKG/install
119cat $CWD/slack-desc > $PKG/install/slack-desc
120
121cd $PKG
122/sbin/makepkg -l y -c n $TMP/iptables-$VERSION-$ARCH-$BUILD.txz
123
Note: See TracBrowser for help on using the repository browser.