source: npl/system/libnftnl/libnftnl.SlackBuild.orig @ 1a19ecd

perl-5.22
Last change on this file since 1a19ecd was 6a55355, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

upgraded because of better ipv6 support

  • Property mode set to 100755
File size: 3.3 KB
Line 
1#!/bin/sh
2
3# Copyright 2014  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23PKGNAM=libnftnl
24VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-1}
26
27NUMJOBS=${NUMJOBS:-" -j7 "}
28
29# Automatically determine the architecture we're building on:
30if [ -z "$ARCH" ]; then
31  case "$( uname -m )" in
32    i?86) export ARCH=i586 ;;
33    arm*) export ARCH=arm ;;
34    # Unless $ARCH is already set, use uname -m for all other archs:
35       *) export ARCH=$( uname -m ) ;;
36  esac
37fi
38
39if [ "$ARCH" = "i586" ]; then
40  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
41  LIBDIRSUFFIX=""
42elif [ "$ARCH" = "s390" ]; then
43  SLKCFLAGS="-O2"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "x86_64" ]; then
46  SLKCFLAGS="-O2 -fPIC"
47  LIBDIRSUFFIX="64"
48else
49  SLKCFLAGS="-O2"
50  LIBDIRSUFFIX=""
51fi
52
53CWD=$(pwd)
54TMP=${TMP:-/tmp}
55PKG=$TMP/package-$PKGNAM
56
57rm -rf $PKG
58mkdir -p $TMP $PKG
59
60cd $TMP
61rm -rf $PKGNAM-$VERSION
62tar xf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
63cd $PKGNAM-$VERSION || exit 1
64
65chown -R root:root .
66find . \
67  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
68  -exec chmod 755 {} \; -o \
69  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
70  -exec chmod 644 {} \;
71
72CFLAGS="$SLKCFLAGS" \
73CXXFLAGS="$SLKCFLAGS" \
74./configure \
75  --prefix=/usr \
76  --libdir=/usr/lib${LIBDIRSUFFIX} \
77  --sysconfdir=/etc \
78  --localstatedir=/var \
79  --mandir=/usr/man \
80  --docdir=/usr/doc/$PKGNAM-$VERSION \
81  --disable-static \
82  --build=$ARCH-slackware-linux || exit 1
83
84make $NUMJOBS || make || exit 1
85make install DESTDIR=$PKG || exit 1
86
87rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la
88
89find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
90  grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
91
92# Compress and if needed symlink the man pages:
93if [ -d $PKG/usr/man ]; then
94  ( cd $PKG/usr/man
95    for manpagedir in $(find . -type d -name "man*") ; do
96      ( cd $manpagedir
97        for eachpage in $( find . -type l -maxdepth 1) ; do
98          ln -s $( readlink $eachpage ).gz $eachpage.gz
99          rm $eachpage
100        done
101        gzip -9 *.?
102      )
103    done
104  )
105fi
106
107mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
108cp -a COPYING* $PKG/usr/doc/$PKGNAM-$VERSION
109
110mkdir -p $PKG/install
111cat $CWD/slack-desc > $PKG/install/slack-desc
112
113cd $PKG
114/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
Note: See TracBrowser for help on using the repository browser.