source: npl/system/lm_sensors/lm_sensors.SlackBuild @ 439f083

Last change on this file since 439f083 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.0 KB
Line 
1#!/bin/bash
2#NEED:linux_src
3#DEP:udev
4
5NAME=lm_sensors
6VER=3.1.2
7TARNAME=lm_sensors-$VER
8CWD=`pwd`
9PKGTMP=/tmp/pkgtmp
10
11mkdir -p $PKGTMP &>/dev/null
12
13tar -xjf $TARNAME.tar.bz2 || exit 1
14
15mkdir -p $PKGTMP/usr/share/man/man8
16 
17#hack voor deze stomme makefile
18#mkdir -p /lib/modules/`uname -r` || exit 1
19#ln -s /usr/src/linux /lib/modules/`uname -r`/build || exit 1
20
21cd $TARNAME || exit 1
22
23#mkdir -p $PKGTMP/etc/udev/rules.d || exit 1
24#./build_tools/genudevrules > $PKGTMP/etc/udev/rules.d/zaptel.rules || exit 1
25
26#patch om genmod iets druit te slopen
27#patch -p0 < ../Makefile.patch || exit 1
28#make -j1 clean || exit 1
29#./configure || exit 1
30make -j1 || exit 1
31make -j1 DESTDIR=$PKGTMP install || exit 1
32
33#genconfig meuk
34#cp $CWD/genzaptelconf $PKGTMP/sbin || exit 1
35#chmod +x $PKGTMP/sbin/* || exit 1
36
37#boot scripts
38#mkdir $PKGTMP/etc/boot.d
39#cp $CWD/zaptel $PKGTMP/etc/boot.d || exit 1
40#chmod +x $PKGTMP/etc/boot.d/* || exit 1
41
42
43cd "$PKGTMP" || exit 1
44makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
45echo $VER > $CWD/$NAME.version &&
46arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.