1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #Strict build-dependencies |
---|
8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
9 | #(this is recommended for most dependencys) |
---|
10 | ##DEP:linux |
---|
11 | ##DEP:linux_src |
---|
12 | ##DEP:openldap |
---|
13 | |
---|
14 | #Loose build-dependencies |
---|
15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
16 | #(not recommended) |
---|
17 | ##DEP:doxygen |
---|
18 | |
---|
19 | |
---|
20 | #######Essential package info. |
---|
21 | #Change these if autodetection fails. |
---|
22 | |
---|
23 | #Name of the Syn-3 package that we are going to create |
---|
24 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
25 | |
---|
26 | #Archive of the sourcefiles to unpack |
---|
27 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
28 | |
---|
29 | #Version of the sourcefiles |
---|
30 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
31 | |
---|
32 | #Architecture that the created binaries run on. |
---|
33 | #Use noarch for scripts. |
---|
34 | ARCH=`uname -m` |
---|
35 | |
---|
36 | ########Build and create the pacakge. |
---|
37 | #Uncomment the stuff that you dont want or need |
---|
38 | mkdir /tmp/pkg |
---|
39 | PKG=/tmp/pkg |
---|
40 | |
---|
41 | #Unpack source |
---|
42 | #(uncomment if not needed) |
---|
43 | syn3_unpack $SRC_ARC || exit 1 |
---|
44 | |
---|
45 | #Directory where the sourcefiles are unpacked. |
---|
46 | #(you might have to adjust this if autodetection fails) |
---|
47 | SRC_DIR=`ls -c|head -1` |
---|
48 | |
---|
49 | cd netdate || exit 1 |
---|
50 | chown -R root:root . || exit 1 |
---|
51 | zcat ../netdate.diff.gz | patch -p1 --backup || exit 1 |
---|
52 | zcat ../netdate.diff2.gz | patch -p1 --backup || exit 1 |
---|
53 | make || exit 1 |
---|
54 | strip netdate || exit 1 |
---|
55 | mkdir -p $PKG/usr/sbin || exit 1 |
---|
56 | cat netdate > $PKG/usr/sbin/netdate || exit 1 |
---|
57 | chmod 755 $PKG/usr/sbin/netdate || exit 1 |
---|
58 | mkdir -p $PKG/usr/man/man8 || exit 1 |
---|
59 | cat netdate.8 | gzip -9c > $PKG/usr/man/man8/netdate.8.gz || exit 1 |
---|
60 | mkdir -p $PKG/usr/doc/netdate || exit 1 |
---|
61 | cp -a COPYRIGHT $PKG/usr/doc/netdate || exit 1 |
---|
62 | |
---|
63 | #after unpacking we can no longer use the default package system :-( |
---|
64 | |
---|
65 | cd /tmp/build |
---|
66 | |
---|
67 | #make main package |
---|
68 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
69 | |
---|
70 | |
---|