[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | |
---|
| 7 | #Strict build-dependencies |
---|
| 8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
| 9 | #(this is recommended for most dependencys) |
---|
| 10 | ##DEP:linux |
---|
| 11 | ##DEP:linux_src |
---|
| 12 | ##DEP:openldap |
---|
| 13 | |
---|
| 14 | #Loose build-dependencies |
---|
| 15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
| 16 | #(not recommended) |
---|
| 17 | ##NEED:doxygen |
---|
| 18 | |
---|
| 19 | #######Essential package info. |
---|
| 20 | #Change these if autodetection fails. |
---|
| 21 | |
---|
| 22 | #Name of the Syn-3 package that we are going to create |
---|
| 23 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 24 | |
---|
| 25 | #Archive of the sourcefiles to unpack |
---|
| 26 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
| 27 | |
---|
| 28 | #Version of the sourcefiles |
---|
| 29 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
| 30 | |
---|
| 31 | #Architecture that the created binaries run on. |
---|
| 32 | #Use noarch for scripts. |
---|
| 33 | ARCH=`uname -m` |
---|
| 34 | |
---|
| 35 | #from this point on, exit on errors: |
---|
| 36 | set -e |
---|
| 37 | |
---|
| 38 | ########Build and create the pacakge. |
---|
| 39 | #Uncomment the stuff that you dont want or need |
---|
| 40 | |
---|
| 41 | #Unpack source |
---|
| 42 | #(uncomment if not needed) |
---|
| 43 | syn3_unpack $SRC_ARC |
---|
| 44 | |
---|
| 45 | #Directory where the sourcefiles are unpacked. |
---|
| 46 | #(you might have to adjust this if autodetection fails) |
---|
| 47 | SRC_DIR=`ls -c|head -1` |
---|
| 48 | |
---|
| 49 | #apply patches |
---|
| 50 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 51 | |
---|
| 52 | pushd $SRC_DIR |
---|
| 53 | |
---|
| 54 | #AUTOMAKE: Configure |
---|
| 55 | #Some usefull stuff you sometimes need to set: |
---|
| 56 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
| 57 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
| 58 | #export VPATH=$LD_LIBRARY_PATH |
---|
| 59 | MAKE_OPTS="" |
---|
| 60 | ./configure --prefix=/usr || exit 1 |
---|
| 61 | |
---|
| 62 | #AUTOMAKE: Compile |
---|
| 63 | make $MAKE_OPTS >/dev/null || exit 1 |
---|
| 64 | |
---|
| 65 | #AUTOMAKE: Install |
---|
| 66 | mkdir -p /tmp/pkg &>/dev/null |
---|
| 67 | #make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1 |
---|
| 68 | PKG=/tmp/pkg |
---|
| 69 | |
---|
| 70 | chown -R root:root . |
---|
| 71 | zcat /tmp/build/routed.18.candidate.final.patch.gz | patch -p1 --backup --verbose -E --suffix=.orig || exit |
---|
| 72 | zcat /tmp/build/netkit-routed-0.17.diff.gz | patch -p1 --backup --verbose -E --suffix=.orig || exit |
---|
| 73 | ./configure --prefix=/usr |
---|
| 74 | make || exit 1 |
---|
| 75 | strip --strip-unneeded ripquery/ripquery routed/routed |
---|
| 76 | mkdir -p $PKG/usr/sbin |
---|
| 77 | cat routed/routed > $PKG/usr/sbin/routed |
---|
| 78 | chmod 755 $PKG/usr/sbin/routed |
---|
| 79 | mkdir -p $PKG/usr/man/man8 |
---|
| 80 | cat routed/routed.8 | gzip -9c > $PKG/usr/man/man8/routed.8.gz |
---|
| 81 | cat ripquery/ripquery > $PKG/usr/sbin/ripquery |
---|
| 82 | chmod 755 $PKG/usr/sbin/ripquery |
---|
| 83 | cat ripquery/ripquery.8 | gzip -9c > $PKG/usr/man/man8/ripquery.8.gz |
---|
| 84 | mkdir -p $PKG/usr/doc/netkit-routed-0.17 |
---|
| 85 | cp -a README $PKG/usr/doc/netkit-routed-0.17 |
---|
| 86 | chown root:root $PKG/usr/doc/netkit-routed-0.17/* |
---|
| 87 | chmod 644 $PKG/usr/doc/netkit-routed-0.17/* |
---|
| 88 | |
---|
| 89 | #strip bins and other stuff |
---|
| 90 | syn3_strip /tmp/pkg || exit 1 |
---|
| 91 | |
---|
| 92 | #move development stuff and create seperate development package |
---|
| 93 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 94 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 95 | |
---|
| 96 | popd |
---|
| 97 | |
---|
| 98 | #make main package |
---|
| 99 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 100 | |
---|
| 101 | |
---|
| 102 | |
---|