[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | |
---|
| 7 | #Strict build-dependencies |
---|
| 8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
| 9 | #(this is recommended for most dependencys) |
---|
| 10 | ##DEP:linux |
---|
| 11 | ##DEP:linux_src |
---|
| 12 | ##DEP:openldap |
---|
| 13 | |
---|
| 14 | #Loose build-dependencies |
---|
| 15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
| 16 | #(not recommended) |
---|
| 17 | ##NEED:doxygen |
---|
| 18 | |
---|
| 19 | #######Essential package info. |
---|
| 20 | #Change these if autodetection fails. |
---|
| 21 | |
---|
| 22 | #Name of the Syn-3 package that we are going to create |
---|
| 23 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 24 | |
---|
| 25 | #Version of the sourcefiles |
---|
| 26 | VER=0.1 |
---|
| 27 | |
---|
| 28 | #Architecture that the created binaries run on. |
---|
| 29 | #Use noarch for scripts. |
---|
| 30 | ARCH=`uname -m` |
---|
| 31 | |
---|
| 32 | #from this point on, exit on errors: |
---|
| 33 | set -e |
---|
| 34 | |
---|
| 35 | #Directory where the sourcefiles are unpacked. |
---|
| 36 | #(you might have to adjust this if autodetection fails) |
---|
| 37 | SRC_DIR=`ls -c|head -1` |
---|
| 38 | |
---|
| 39 | #apply patches |
---|
| 40 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 41 | #cp -R etc $SRC_DIR |
---|
| 42 | |
---|
| 43 | #AUTOMAKE: Install |
---|
| 44 | mkdir -p /tmp/pkg &>/dev/null |
---|
| 45 | #make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1 |
---|
| 46 | PKG=/tmp/pkg |
---|
| 47 | #popd |
---|
| 48 | mkdir -p $PKG/etc/rc.d |
---|
| 49 | cp etc/*new $PKG/etc |
---|
| 50 | cp etc/rc.d/*new $PKG/etc/rc.d |
---|
| 51 | #make main package |
---|
| 52 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 53 | |
---|
| 54 | |
---|
| 55 | |
---|