source: npl/system/network_scripts/network_scripts.SlackBuild @ a39aa4c

perl-5.22
Last change on this file since a39aa4c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.6 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#######Essential package info.
20#Change these if autodetection fails.
21
22#Name of the Syn-3 package that we are going to create
23NAME=`basename $0|sed 's/.SlackBuild//'`
24
25#Version of the sourcefiles
26VER=0.1
27
28#Architecture that the created binaries run on.
29#Use noarch for scripts.
30ARCH=`uname -m`
31
32#from this point on, exit on errors:
33set -e
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41#cp -R etc $SRC_DIR
42
43#AUTOMAKE: Install
44mkdir -p /tmp/pkg &>/dev/null
45#make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1
46PKG=/tmp/pkg
47#popd
48mkdir -p $PKG/etc/rc.d
49cp etc/*new $PKG/etc
50cp etc/rc.d/*new $PKG/etc/rc.d
51#make main package
52syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
53
54
55
Note: See TracBrowser for help on using the repository browser.