perl-5.22
Last change
on this file since f9ce31e was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
513 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #DEP:Linux_PAM |
---|
| 3 | VER=2.0 |
---|
| 4 | CWD=`pwd` |
---|
| 5 | |
---|
| 6 | gcc -o pam_auth pam_auth-2.0.c -lpam -ldl |
---|
| 7 | |
---|
| 8 | mkdir -p tmp/usr/bin |
---|
| 9 | cp pam_auth tmp/usr/bin |
---|
| 10 | |
---|
| 11 | mkdir -p tmp/etc/pam.d |
---|
| 12 | cp system-auth tmp/etc/pam.d |
---|
| 13 | |
---|
| 14 | |
---|
| 15 | NAME=`echo $0|cut -f2 -d'.'` |
---|
| 16 | VER=2.0 |
---|
| 17 | ARCH=`arch` |
---|
| 18 | |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | |
---|
| 22 | #strip bins and other stuff |
---|
| 23 | syn3_strip tmp || exit 1 |
---|
| 24 | |
---|
| 25 | |
---|
| 26 | #move development stuff and create seperate development package |
---|
| 27 | syn3_move_dev tmp pkgdev || exit 1 |
---|
| 28 | syn3_makepkg pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 29 | |
---|
| 30 | #make main package |
---|
| 31 | syn3_makepkg tmp $NAME $VER $ARCH || exit 1 |
---|
Note: See
TracBrowser
for help on using the repository browser.