source: npl/system/pam_auth/pam_auth.SlackBuild @ 105afb5

Last change on this file since 105afb5 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 513 bytes
Line 
1#!/bin/bash
2#DEP:Linux_PAM
3VER=2.0
4CWD=`pwd`
5
6gcc -o pam_auth pam_auth-2.0.c -lpam -ldl
7
8mkdir -p tmp/usr/bin
9cp pam_auth tmp/usr/bin
10
11mkdir -p tmp/etc/pam.d
12cp system-auth tmp/etc/pam.d
13
14
15NAME=`echo $0|cut -f2 -d'.'`
16VER=2.0
17ARCH=`arch`
18
19
20
21
22#strip bins and other stuff
23syn3_strip tmp || exit 1
24
25
26#move development stuff and create seperate development package
27syn3_move_dev tmp pkgdev || exit 1
28syn3_makepkg pkgdev $NAME""_dev $VER $ARCH || exit 1
29
30#make main package
31syn3_makepkg tmp $NAME $VER $ARCH || exit 1
Note: See TracBrowser for help on using the repository browser.