source: npl/system/pciutils/pciutils.SlackBuild @ 4e95a55

perl-5.22
Last change on this file since 4e95a55 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.2 KB
RevLine 
[c5c522c]1#!/bin/bash
2#for wget:
3
4# Set initial variables:
5CWD=`pwd`
6if [ "$TMP" = "" ]; then
7  TMP=/tmp
8fi
9PKG=$TMP/pkg
10NAME=pciutils
11TARVERSION=3.0.3
12VERSION=3.0.3
13ARCH=`arch`
14
15mkdir -p $PKG
16
17#prepare sources
18tar -xjf $NAME-$TARVERSION.tar.bz2
19cd $NAME-$TARVERSION
20#for PATCH in ../*.patch; do
21#       patch -p1 < $PATCH || exit 1
22#done
23
24./update-pciids.sh || exit 1
25 
26#build
27make SHAREDIR=/usr/share/hwdata PREFIX=/usr || exit 1
28make SHAREDIR=/usr/share/hwdata PREFIX=/usr DESTDIR=$PKG install || exit 1
29
30#ivm linkbeep willen we GEEN gezipte database.
31#hack update-pciids om!
32sed -i 's/PCI_COMPRESSED_IDS=.*/PCI_COMPRESSED_IDS=/' $PKG/usr/sbin/update-pciids  || exit 1
33sed -i 's@/usr/share/hwdata/pci.ids.gz@/usr/share/hwdata/pci.ids@' $PKG/usr/sbin/update-pciids  || exit 1
34gunzip $PKG/usr/share/hwdata/* || exit 1
35
36#copieer lib gedeelte handmatig
37mkdir -p $PKG/usr/lib || exit 1
38cp lib/libpci.a $PKG/usr/lib || exit 1
39mkdir -p $PKG/usr/include/pci || exit 1
40cp lib/{internal.h,pread.h,types.h,pci.h,sysdep.h,header.h,config.h} $PKG/usr/include/pci || exit 1
41
42
43
44# Create the package:
45cd $PKG
46#makepkg -l y -c n $TMP/logrotate-$VERSION-$ARCH-$BUILD.tgz
47makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
48echo $VERSION > $CWD/$NAME.version &&
49arch > $CWD/$NAME.arch
50
Note: See TracBrowser for help on using the repository browser.