[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | |
---|
| 7 | #DEP:ncurses |
---|
| 8 | |
---|
| 9 | #######Essential package info. |
---|
| 10 | #Change these if autodetection fails. |
---|
| 11 | |
---|
| 12 | #Name of the Syn-3 package that we are going to create |
---|
| 13 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 14 | |
---|
| 15 | #Archive of the sourcefiles to unpack |
---|
| 16 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
| 17 | |
---|
| 18 | #Version of the sourcefiles |
---|
| 19 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
| 20 | |
---|
| 21 | #Architecture that the created binaries run on. |
---|
| 22 | #Use noarch for scripts. |
---|
| 23 | ARCH=`uname -m` |
---|
| 24 | |
---|
| 25 | #from this point on, exit on errors: |
---|
| 26 | set -e |
---|
| 27 | |
---|
| 28 | ########Build and create the pacakge. |
---|
| 29 | #Uncomment the stuff that you dont want or need |
---|
| 30 | |
---|
| 31 | #Unpack source |
---|
| 32 | #(uncomment if not needed) |
---|
| 33 | syn3_unpack $SRC_ARC |
---|
| 34 | |
---|
| 35 | #Directory where the sourcefiles are unpacked. |
---|
| 36 | #(you might have to adjust this if autodetection fails) |
---|
| 37 | SRC_DIR=`ls -c|head -1` |
---|
| 38 | |
---|
| 39 | #apply patches |
---|
| 40 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 41 | |
---|
| 42 | pushd $SRC_DIR |
---|
| 43 | |
---|
| 44 | #AUTOMAKE: Configure |
---|
| 45 | #Some usefull stuff you sometimes need to set: |
---|
| 46 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
| 47 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
| 48 | #export VPATH=$LD_LIBRARY_PATH |
---|
| 49 | MAKE_OPTS="" |
---|
| 50 | ./configure --prefix=/usr --bindir=/bin --datarootdir=/usr || exit 1 |
---|
| 51 | |
---|
| 52 | #AUTOMAKE: Compile |
---|
| 53 | make $MAKE_OPTS || exit 1 |
---|
| 54 | |
---|
| 55 | #AUTOMAKE: Test (optional) |
---|
| 56 | if grep ^test: Makefile; then |
---|
| 57 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 58 | make $MAKE_OPTS test || exit 1 |
---|
| 59 | elif grep ^check: Makefile; then |
---|
| 60 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 61 | make $MAKE_OPTS check || exit 1 |
---|
| 62 | fi |
---|
| 63 | |
---|
| 64 | #AUTOMAKE: Install |
---|
| 65 | mkdir -p /tmp/pkg &>/dev/null |
---|
| 66 | make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1 |
---|
| 67 | popd |
---|
| 68 | |
---|
| 69 | #strip bins and other stuff |
---|
| 70 | syn3_strip /tmp/pkg || exit 1 |
---|
| 71 | |
---|
| 72 | #move development stuff and create seperate development package |
---|
| 73 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 74 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 75 | |
---|
| 76 | #make main package |
---|
| 77 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 78 | |
---|
| 79 | |
---|
| 80 | |
---|