source: npl/system/sed/sed.SlackBuild.orig @ 3b59591

Last change on this file since 3b59591 was 2154c77, checked in by Edwin Eefting <edwin@datux.nl>, 3 years ago

various updates

  • Property mode set to 100755
File size: 3.4 KB
RevLine 
[2154c77]1#!/bin/sh
2
3# Copyright 2005-2013  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=sed
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28CWD=$(pwd)
29TMP=${TMP:-/tmp}
30PKG=$TMP/package-sed
31
32# Automatically determine the architecture we're building on:
33if [ -z "$ARCH" ]; then
34  case "$( uname -m )" in
35    i?86) export ARCH=i486 ;;
36    arm*) export ARCH=arm ;;
37    # Unless $ARCH is already set, use uname -m for all other archs:
38       *) export ARCH=$( uname -m ) ;;
39  esac
40fi
41
42if [ "$ARCH" = "i386" ]; then
43  SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "i486" ]; then
46  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
47  LIBDIRSUFFIX=""
48elif [ "$ARCH" = "s390" ]; then
49  SLKCFLAGS="-O2"
50  LIBDIRSUFFIX=""
51elif [ "$ARCH" = "x86_64" ]; then
52  SLKCFLAGS="-O2 -fPIC"
53  LIBDIRSUFFIX="64"
54fi
55
56rm -rf $PKG
57mkdir -p $PKG $PKG
58
59cd $TMP
60rm -rf sed-$VERSION
61tar xvf $CWD/sed-$VERSION.tar.?z* || exit 1
62cd sed-$VERSION
63chown -R root:root .
64find . -perm 777 -exec chmod 755 {} \;
65find . -perm 664 -exec chmod 644 {} \;
66
67CFLAGS="$SLKCFLAGS" \
68./configure \
69  --prefix=/usr \
70  --libdir=/usr/lib${LIBDIRSUFFIX} \
71  --mandir=/usr/man \
72  --infodir=/usr/info \
73  --docdir=/usr/doc/sed-$VERSION \
74  --build=$ARCH-slackware-linux
75
76make $NUMJOBS || make || exit 1
77make install DESTDIR=$PKG || exit 1
78
79mkdir -p $PKG/bin
80mv $PKG/usr/bin/sed $PKG/bin
81( cd $PKG/usr/bin ; ln -sf /bin/sed . )
82
83( cd $PKG
84  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
85    xargs strip --strip-unneeded 2> /dev/null
86  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
87    xargs strip --strip-unneeded 2> /dev/null
88) || true
89
90# Compress and if needed symlink the man pages:
91if [ -d $PKG/usr/man ]; then
92  ( cd $PKG/usr/man
93    for manpagedir in $(find . -type d -name "man*") ; do
94      ( cd $manpagedir
95        for eachpage in $( find . -type l -maxdepth 1) ; do
96          ln -s $( readlink $eachpage ).gz $eachpage.gz
97          rm $eachpage
98        done
99        gzip -9 *.?
100      )
101    done
102  )
103fi
104
105rm -f $PKG/usr/info/dir
106gzip -9 $PKG/usr/info/*
107
108mkdir -p $PKG/usr/doc/sed-$VERSION
109cp -a \
110  AUTHORS BUGS COPYING* INSTALL NEWS README* THANKS \
111  $PKG/usr/doc/sed-$VERSION
112
113mkdir -p $PKG/install
114cat $CWD/slack-desc > $PKG/install/slack-desc
115
116cd $PKG
117/sbin/makepkg -l y -c n $TMP/sed-$VERSION-$ARCH-$BUILD.txz
118
Note: See TracBrowser for help on using the repository browser.