1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #Strict build-dependencies |
---|
8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
9 | #(this is recommended for most dependencys) |
---|
10 | ##DEP:linux |
---|
11 | ##DEP:linux_src |
---|
12 | ##DEP:openldap |
---|
13 | #DEP:libusb1_dev |
---|
14 | #DEP:libusb1 |
---|
15 | |
---|
16 | #Loose build-dependencies |
---|
17 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
18 | #(not recommended) |
---|
19 | ##NEED:doxygen |
---|
20 | |
---|
21 | #######Essential package info. |
---|
22 | #Change these if autodetection fails. |
---|
23 | |
---|
24 | #Name of the Syn-3 package that we are going to create |
---|
25 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
26 | |
---|
27 | #Archive of the sourcefiles to unpack |
---|
28 | SRC_ARC="usbutils-004.tar.gz" |
---|
29 | |
---|
30 | #Version of the sourcefiles |
---|
31 | VER=4 |
---|
32 | |
---|
33 | #Architecture that the created binaries run on. |
---|
34 | #Use noarch for scripts. |
---|
35 | ARCH=`uname -m` |
---|
36 | |
---|
37 | #from this point on, exit on errors: |
---|
38 | set -e |
---|
39 | |
---|
40 | ########Build and create the pacakge. |
---|
41 | #Uncomment the stuff that you dont want or need |
---|
42 | CWD=`pwd` |
---|
43 | #Unpack source |
---|
44 | #(uncomment if not needed) |
---|
45 | syn3_unpack $SRC_ARC |
---|
46 | |
---|
47 | #Directory where the sourcefiles are unpacked. |
---|
48 | #(you might have to adjust this if autodetection fails) |
---|
49 | SRC_DIR=`ls -c|head -1` |
---|
50 | |
---|
51 | #apply patches |
---|
52 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
53 | |
---|
54 | pushd $SRC_DIR |
---|
55 | #nieuwe usbID's opvragen, zodat package initieel nieuwe ID's heeft |
---|
56 | ./update-usbids.sh.in |
---|
57 | #AUTOMAKE: Configure |
---|
58 | #Some usefull stuff you sometimes need to set: |
---|
59 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
60 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
61 | #export VPATH=$LD_LIBRARY_PATH |
---|
62 | #export CFLAGS="-std=c89" |
---|
63 | #export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html |
---|
64 | MAKE_OPTS="" |
---|
65 | ./configure --prefix=/usr --libdir=/usr/lib || exit 1 |
---|
66 | |
---|
67 | #AUTOMAKE: Compile |
---|
68 | make $MAKE_OPTS || exit 1 |
---|
69 | |
---|
70 | #AUTOMAKE: Test (optional) |
---|
71 | if grep ^test: Makefile; then |
---|
72 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
73 | make $MAKE_OPTS test || exit 1 |
---|
74 | elif grep ^check: Makefile; then |
---|
75 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
76 | make $MAKE_OPTS check || exit 1 |
---|
77 | fi |
---|
78 | #AUTOMAKE: Install |
---|
79 | mkdir -p /tmp/pkg &>/dev/null |
---|
80 | make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1 |
---|
81 | |
---|
82 | # En uiteraard mag de vette postinstall niet ontbreken. |
---|
83 | mkdir -p /tmp/pkg/etc/postinst.d/ |
---|
84 | cp $CWD/post.usbutils /tmp/pkg/etc/postinst.d/post.usbutils |
---|
85 | chmod +x /tmp/pkg/etc/postinst.d/post.usbutils |
---|
86 | |
---|
87 | #cron job om maandelijks de usb id database te updaten |
---|
88 | mkdir -p /tmp/pkg/etc/cron.monthly |
---|
89 | cp $CWD/usbutils.cron /tmp/pkg/etc/cron.monthly |
---|
90 | chmod 550 /tmp/pkg/etc/cron.monthly/usbutils.cron |
---|
91 | |
---|
92 | popd |
---|
93 | |
---|
94 | #strip bins and other stuff |
---|
95 | syn3_strip /tmp/pkg || exit 1 |
---|
96 | |
---|
97 | #move development stuff and create seperate development package |
---|
98 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
99 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
100 | |
---|
101 | #make main package |
---|
102 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
103 | |
---|
104 | |
---|
105 | |
---|