source: npl/system/v86d/v86d.SlackBuild @ 08cf024

Last change on this file since 08cf024 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2##NEED:klibc
3##NEED:linux_src
4
5#######Essential package info.
6#Change these if autodetection fails.
7
8#Name of the Syn-3 package that we are going to create
9NAME=`basename $0|sed 's/.SlackBuild//'`
10
11#Archive of the sourcefiles to unpack
12SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
13
14#Version of the sourcefiles
15VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
16
17#Architecture that the created binaries run on.
18#Use noarch for scripts.
19ARCH=`uname -m`
20
21#from this point on, exit on errors:
22set -e
23
24########Build and create the pacakge.
25#Uncomment the stuff that you dont want or need
26
27#Unpack source
28#(uncomment if not needed)
29syn3_unpack $SRC_ARC
30
31#Directory where the sourcefiles are unpacked.
32#(you might have to adjust this if autodetection fails)
33SRC_DIR=`ls -c|head -1`
34
35#apply patches
36#patch -p1 -d $SRC_DIR < v86d_0.1.10-1.diff || exit 1
37
38pushd $SRC_DIR
39
40#AUTOMAKE: Configure
41#Some usefull stuff you sometimes need to set:
42#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
43#export LD_LIBRARY_PATH=/usr/lib/mysql
44#export VPATH=$LD_LIBRARY_PATH
45#MAKE_OPTS="KDIR=/usr/src/linux"
46#./configure --with-klibc --with-x86emu || exit 1
47#./configure --with-klibc || exit 1
48#./configure --default --with-x86emu || exit 1
49#./configure --default || exit 1
50#arch:
51./configure --with-x86emu
52
53#AUTOMAKE: Compile
54make $MAKE_OPTS || exit 1
55
56#AUTOMAKE: Test (optional)
57if grep ^test: Makefile; then
58        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
59        make $MAKE_OPTS test || exit 1
60elif grep ^check: Makefile; then
61        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
62        make $MAKE_OPTS check || exit 1
63fi
64
65#AUTOMAKE: Install
66mkdir -p /tmp/pkg &>/dev/null
67make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
68popd
69
70#strip bins and other stuff
71syn3_strip /tmp/pkg || exit 1
72
73#move development stuff and create seperate development package
74syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
75syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
76
77#make main package
78syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
79
80
81
Note: See TracBrowser for help on using the repository browser.