Last change
on this file since 08cf024 was
94a6f37,
checked in by Edwin Eefting <edwin@datux.nl>, 6 years ago
|
iptables upgrade for kernel 4.9
|
-
Property mode set to
100755
|
File size:
597 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #NEED:linux_src |
---|
| 3 | #NEED:linux |
---|
[94a6f37] | 4 | #DEP:iptables |
---|
[c5c522c] | 5 | NAME=xtables_addons |
---|
| 6 | SRCFILE=xtables-addons |
---|
[94a6f37] | 7 | VER=3.2 |
---|
[c5c522c] | 8 | CWD=`pwd` |
---|
| 9 | PKGTMP=/tmp/pkgtmp |
---|
| 10 | |
---|
| 11 | mkdir -p $PKGTMP &>/dev/null |
---|
| 12 | |
---|
[94a6f37] | 13 | tar -xf $SRCFILE-$VER.tar.xz || exit 1 |
---|
[c5c522c] | 14 | cd $SRCFILE-$VER || exit 1 |
---|
| 15 | |
---|
| 16 | ./configure --prefix=/usr || exit 1 |
---|
| 17 | make || exit 1 |
---|
| 18 | make install DESTDIR=$PKGTMP || exit 1 |
---|
| 19 | |
---|
| 20 | # postinstaller |
---|
| 21 | mkdir -p $PKGTMP/etc/postinst.d |
---|
| 22 | cp ../post.xtables_addons $PKGTMP/etc/postinst.d || exit 1 |
---|
| 23 | chmod +x $PKGTMP/etc/postinst.d/* |
---|
| 24 | |
---|
| 25 | cd "$PKGTMP" || exit 1 |
---|
| 26 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 27 | echo $VER > $CWD/$NAME.version && |
---|
| 28 | arch > $CWD/$NAME.arch |
---|
| 29 | |
---|
Note: See
TracBrowser
for help on using the repository browser.