gcc484perl-5.22
Last change
on this file since a1525ed was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
601 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #NEED:linux_src |
---|
| 3 | #NEED:linux |
---|
| 4 | #NEED:iptables |
---|
| 5 | NAME=xtables_addons |
---|
| 6 | SRCFILE=xtables-addons |
---|
| 7 | VER=1.21 |
---|
| 8 | CWD=`pwd` |
---|
| 9 | PKGTMP=/tmp/pkgtmp |
---|
| 10 | |
---|
| 11 | mkdir -p $PKGTMP &>/dev/null |
---|
| 12 | |
---|
| 13 | tar -xjf $SRCFILE-$VER.tar.bz2 || exit 1 |
---|
| 14 | cd $SRCFILE-$VER || exit 1 |
---|
| 15 | |
---|
| 16 | ./configure --prefix=/usr || exit 1 |
---|
| 17 | make || exit 1 |
---|
| 18 | make install DESTDIR=$PKGTMP || exit 1 |
---|
| 19 | |
---|
| 20 | # postinstaller |
---|
| 21 | mkdir -p $PKGTMP/etc/postinst.d |
---|
| 22 | cp ../post.xtables_addons $PKGTMP/etc/postinst.d || exit 1 |
---|
| 23 | chmod +x $PKGTMP/etc/postinst.d/* |
---|
| 24 | |
---|
| 25 | cd "$PKGTMP" || exit 1 |
---|
| 26 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 27 | echo $VER > $CWD/$NAME.version && |
---|
| 28 | arch > $CWD/$NAME.arch |
---|
| 29 | |
---|
Note: See
TracBrowser
for help on using the repository browser.