source: npl/system/xtables_addons/xtables_addons.SlackBuild

Last change on this file was 94a6f37, checked in by Edwin Eefting <edwin@datux.nl>, 6 years ago

iptables upgrade for kernel 4.9

  • Property mode set to 100755
File size: 597 bytes
Line 
1#!/bin/bash
2#NEED:linux_src
3#NEED:linux
4#DEP:iptables
5NAME=xtables_addons
6SRCFILE=xtables-addons
7VER=3.2
8CWD=`pwd`
9PKGTMP=/tmp/pkgtmp
10
11mkdir -p $PKGTMP &>/dev/null
12
13tar -xf $SRCFILE-$VER.tar.xz || exit 1
14cd $SRCFILE-$VER || exit 1
15
16./configure --prefix=/usr || exit 1
17make || exit 1
18make install DESTDIR=$PKGTMP || exit 1
19
20# postinstaller
21mkdir -p $PKGTMP/etc/postinst.d
22cp ../post.xtables_addons  $PKGTMP/etc/postinst.d || exit 1
23chmod +x  $PKGTMP/etc/postinst.d/*
24
25cd "$PKGTMP" || exit 1
26makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
27echo $VER > $CWD/$NAME.version &&
28arch > $CWD/$NAME.arch
29
Note: See TracBrowser for help on using the repository browser.