source: npl/system/xtables_addons/xtables_addons.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 601 bytes
Line 
1#!/bin/bash
2#NEED:linux_src
3#NEED:linux
4#NEED:iptables
5NAME=xtables_addons
6SRCFILE=xtables-addons
7VER=1.21
8CWD=`pwd`
9PKGTMP=/tmp/pkgtmp
10
11mkdir -p $PKGTMP &>/dev/null
12
13tar -xjf $SRCFILE-$VER.tar.bz2 || exit 1
14cd $SRCFILE-$VER || exit 1
15
16./configure --prefix=/usr || exit 1
17make || exit 1
18make install DESTDIR=$PKGTMP || exit 1
19
20# postinstaller
21mkdir -p $PKGTMP/etc/postinst.d
22cp ../post.xtables_addons  $PKGTMP/etc/postinst.d || exit 1
23chmod +x  $PKGTMP/etc/postinst.d/*
24
25cd "$PKGTMP" || exit 1
26makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
27echo $VER > $CWD/$NAME.version &&
28arch > $CWD/$NAME.arch
29
Note: See TracBrowser for help on using the repository browser.