source: npl/virt/qemu/qemu.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.3 KB
Line 
1#!/bin/bash
2#DEP:glib2
3#DEP:spice
4#DEP:spice_protocol
5#DEP:pixman
6#DEP:openssl
7#DEP:usbredir
8#DEP:bzip2
9#DEP:zlib
10
11
12#######Essential package info.
13#Change these if autodetection fails.
14
15#Name of the Syn-3 package that we are going to create
16NAME=`basename $0|sed 's/.SlackBuild//'`
17
18#Archive of the sourcefiles to unpack
19SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
20
21#Version of the sourcefiles
22VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
23
24#Architecture that the created binaries run on.
25#Use noarch for scripts.
26ARCH=`uname -m`
27
28#from this point on, exit on errors:
29set -e
30
31########Build and create the pacakge.
32#Uncomment the stuff that you dont want or need
33
34#Unpack source
35#(uncomment if not needed)
36syn3_unpack $SRC_ARC
37
38#Directory where the sourcefiles are unpacked.
39#(you might have to adjust this if autodetection fails)
40SRC_DIR=`ls -c|head -1`
41
42#apply patches
43#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
44
45pushd $SRC_DIR
46
47#AUTOMAKE: Configure
48#Some usefull stuff you sometimes need to set:
49#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
50#export LD_LIBRARY_PATH=/usr/lib/mysql
51#export VPATH=$LD_LIBRARY_PATH
52#export CFLAGS="-std=c89"
53#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
54MAKE_OPTS="-j10"
55#./configure --target-list=x86_64-softmmu --prefix=/usr  || exit 1
56./configure --prefix=/usr --enable-spice --enable-usb-redir || exit 1
57
58#AUTOMAKE: Compile
59make $MAKE_OPTS || exit 1
60
61#AUTOMAKE: Test (optional)
62if grep ^test: Makefile; then
63        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
64        make $MAKE_OPTS test || exit 1
65elif grep ^check: Makefile; then
66        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
67        make $MAKE_OPTS check || exit 1
68fi
69
70#AUTOMAKE: Install
71mkdir -p /tmp/pkg &>/dev/null
72make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
73popd
74
75#strip bins and other stuff
76syn3_strip /tmp/pkg || exit 1
77
78#move development stuff and create seperate development package
79syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
80syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
81
82#make main package
83syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
84
85
86
Note: See TracBrowser for help on using the repository browser.