[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #DEP:libusb1 |
---|
| 3 | |
---|
| 4 | |
---|
| 5 | #######Essential package info. |
---|
| 6 | #Change these if autodetection fails. |
---|
| 7 | |
---|
| 8 | #Name of the Syn-3 package that we are going to create |
---|
| 9 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 10 | |
---|
| 11 | #Archive of the sourcefiles to unpack |
---|
| 12 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
| 13 | |
---|
| 14 | #Version of the sourcefiles |
---|
| 15 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
| 16 | |
---|
| 17 | #Architecture that the created binaries run on. |
---|
| 18 | #Use noarch for scripts. |
---|
| 19 | ARCH=`uname -m` |
---|
| 20 | |
---|
| 21 | #from this point on, exit on errors: |
---|
| 22 | set -e |
---|
| 23 | |
---|
| 24 | ########Build and create the pacakge. |
---|
| 25 | #Uncomment the stuff that you dont want or need |
---|
| 26 | |
---|
| 27 | #Unpack source |
---|
| 28 | #(uncomment if not needed) |
---|
| 29 | syn3_unpack $SRC_ARC |
---|
| 30 | |
---|
| 31 | #Directory where the sourcefiles are unpacked. |
---|
| 32 | #(you might have to adjust this if autodetection fails) |
---|
| 33 | SRC_DIR=`ls -c|head -1` |
---|
| 34 | |
---|
| 35 | #apply patches |
---|
| 36 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 37 | |
---|
| 38 | pushd $SRC_DIR |
---|
| 39 | |
---|
| 40 | #AUTOMAKE: Configure |
---|
| 41 | #Some usefull stuff you sometimes need to set: |
---|
| 42 | #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" |
---|
| 43 | #export LD_LIBRARY_PATH=/usr/lib/mysql |
---|
| 44 | #export VPATH=$LD_LIBRARY_PATH |
---|
| 45 | #export CFLAGS="-std=c89" |
---|
| 46 | #export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html |
---|
| 47 | MAKE_OPTS="" |
---|
| 48 | ./configure --prefix=/usr || exit 1 |
---|
| 49 | |
---|
| 50 | #AUTOMAKE: Compile |
---|
| 51 | make $MAKE_OPTS || exit 1 |
---|
| 52 | |
---|
| 53 | #AUTOMAKE: Test (optional) |
---|
| 54 | if grep ^test: Makefile; then |
---|
| 55 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 56 | make $MAKE_OPTS test || exit 1 |
---|
| 57 | elif grep ^check: Makefile; then |
---|
| 58 | make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 |
---|
| 59 | make $MAKE_OPTS check || exit 1 |
---|
| 60 | fi |
---|
| 61 | |
---|
| 62 | #AUTOMAKE: Install |
---|
| 63 | mkdir -p /tmp/pkg &>/dev/null |
---|
| 64 | make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1 |
---|
| 65 | popd |
---|
| 66 | |
---|
| 67 | #strip bins and other stuff |
---|
| 68 | syn3_strip /tmp/pkg || exit 1 |
---|
| 69 | |
---|
| 70 | #move development stuff and create seperate development package |
---|
| 71 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 72 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 73 | |
---|
| 74 | #make main package |
---|
| 75 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 76 | |
---|
| 77 | |
---|
| 78 | |
---|