source: npl/webapps/Trac/Trac.SlackBuild.dis @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#DEP:python
3#DEP:python_setuptools
4
5#######Essential package info.
6#Change these if autodetection fails.
7
8#Name of the Syn-3 package that we are going to create
9NAME=`basename $0|sed 's/.SlackBuild//'`
10
11#Archive of the sourcefiles to unpack
12SRC_ARC=`ls *.tar.*`
13
14#Version of the sourcefiles
15VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
16
17#Directory of the sourcefiles to build (after optional unpacking)
18SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
19
20#Architecture that the created binaries run on.
21#Use noarch for scripts.
22ARCH=`uname -m`
23
24
25########Build and create the pacakge.
26#Uncomment the stuff that you dont want or need
27
28#webportal stuff
29mkdir -p /tmp/pkg/var/www/htdocs/syn3/tracportal/
30cp webportal/* /tmp/pkg/var/www/htdocs/syn3/tracportal/ || exit 1
31
32#postinst
33mkdir -p /tmp/pkg/etc/postinst.d
34cp post.* /tmp/pkg/etc/postinst.d || exit 1
35chmod +x /tmp/pkg/etc/postinst.d/* || exit 1
36
37#apache config
38mkdir -p /tmp/pkg/etc/apache2/conf.d
39cp trac.conf /tmp/pkg/etc/apache2/conf.d || exit 1
40
41
42#Unpack source
43#(uncomment if not needed)
44syn3_unpack $SRC_ARC || exit 1
45
46#apply patches
47#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
48
49pushd $SRC_DIR || exit 1
50python setup.py install --root=/tmp/pkg || exit 1
51popd
52
53#scripts and stuff to create new syn3 trac env.
54mkdir -p /tmp/pkg/usr/share/trac/syn3_defaults
55cp defaults/* /tmp/pkg/usr/share/trac/syn3_defaults
56mkdir /tmp/pkg/usr/bin
57cp syn3-newtrac /tmp/pkg/usr/bin || exit 1
58chmod +x /tmp/pkg/usr/bin/syn3-newtrac || exit 1
59
60#wsgi stuff
61mkdir -p /tmp/pkg//usr/share/trac/cgi-bin
62cp trac.wsgi /tmp/pkg//usr/share/trac/cgi-bin || exit 1
63
64#strip bins and other stuff
65syn3_strip /tmp/pkg || exit 1
66
67#move development stuff and create seperate development package
68syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
69syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
70
71#make main package
72syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
73
74
Note: See TracBrowser for help on using the repository browser.