source: npl/webapps/Trac/Trac.SlackBuild @ cd5d2d4

gcc484ntopperl-5.22
Last change on this file since cd5d2d4 was cd5d2d4, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

trac upgrade to 1.2

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#DEP:python
3#DEP:python_setuptools
4#DEP:python_Genshi
5
6#######Essential package info.
7#Change these if autodetection fails.
8
9#Name of the Syn-3 package that we are going to create
10NAME=`basename $0|sed 's/.SlackBuild//'`
11
12#Archive of the sourcefiles to unpack
13SRC_ARC=`ls *.tar.*`
14
15#Version of the sourcefiles
16VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
17
18#Directory of the sourcefiles to build (after optional unpacking)
19SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
20
21#Architecture that the created binaries run on.
22#Use noarch for scripts.
23ARCH=`uname -m`
24
25
26########Build and create the pacakge.
27#Uncomment the stuff that you dont want or need
28
29#webportal stuff
30mkdir -p /tmp/pkg/var/www/htdocs/syn3/tracportal/
31cp webportal/* /tmp/pkg/var/www/htdocs/syn3/tracportal/ || exit 1
32
33#postinst
34mkdir -p /tmp/pkg/etc/postinst.d
35cp post.* /tmp/pkg/etc/postinst.d || exit 1
36chmod +x /tmp/pkg/etc/postinst.d/* || exit 1
37
38#apache config
39mkdir -p /tmp/pkg/etc/apache2/conf.d
40cp trac.conf /tmp/pkg/etc/apache2/conf.d || exit 1
41
42
43#Unpack source
44#(uncomment if not needed)
45syn3_unpack $SRC_ARC || exit 1
46
47#apply patches
48#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
49
50pushd $SRC_DIR || exit 1
51python setup.py install --root=/tmp/pkg || exit 1
52popd
53
54#scripts and stuff to create new syn3 trac env.
55mkdir -p /tmp/pkg/usr/share/trac/syn3_defaults
56cp defaults/* /tmp/pkg/usr/share/trac/syn3_defaults
57mkdir /tmp/pkg/usr/bin
58cp syn3-newtrac /tmp/pkg/usr/bin || exit 1
59chmod +x /tmp/pkg/usr/bin/syn3-newtrac || exit 1
60
61#wsgi stuff
62mkdir -p /tmp/pkg//usr/share/trac/cgi-bin
63cp trac.wsgi /tmp/pkg//usr/share/trac/cgi-bin || exit 1
64
65#strip bins and other stuff
66syn3_strip /tmp/pkg || exit 1
67
68#move development stuff and create seperate development package
69syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
70syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
71
72#make main package
73syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
74
75
Note: See TracBrowser for help on using the repository browser.