source: npl/webapps/Trac/Trac.SlackBuild @ 26ffad7

Last change on this file since 26ffad7 was 8b8e03e, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

fixes and updates for trac

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#DEP:python
3#DEP:python_setuptools
4#DEP:python_Genshi
5#DEP:postgresql
6#DEP:python_pyPgSQL
7
8#######Essential package info.
9#Change these if autodetection fails.
10
11#Name of the Syn-3 package that we are going to create
12NAME=`basename $0|sed 's/.SlackBuild//'`
13
14#Archive of the sourcefiles to unpack
15SRC_ARC=`ls *.tar.*`
16
17#Version of the sourcefiles
18VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
19
20#Directory of the sourcefiles to build (after optional unpacking)
21SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
22
23#Architecture that the created binaries run on.
24#Use noarch for scripts.
25ARCH=`uname -m`
26
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#webportal stuff
32mkdir -p /tmp/pkg/var/www/htdocs/syn3/tracportal/
33cp webportal/* /tmp/pkg/var/www/htdocs/syn3/tracportal/ || exit 1
34
35#postinst
36mkdir -p /tmp/pkg/etc/postinst.d
37cp post.* /tmp/pkg/etc/postinst.d || exit 1
38chmod +x /tmp/pkg/etc/postinst.d/* || exit 1
39
40#apache config
41mkdir -p /tmp/pkg/etc/apache2/conf.d
42cp trac.conf /tmp/pkg/etc/apache2/conf.d || exit 1
43
44
45#Unpack source
46#(uncomment if not needed)
47syn3_unpack $SRC_ARC || exit 1
48
49#apply patches
50#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
51
52pushd $SRC_DIR || exit 1
53python setup.py install --root=/tmp/pkg || exit 1
54popd
55
56#scripts and stuff to create new syn3 trac env.
57mkdir -p /tmp/pkg/usr/share/trac/syn3_defaults
58cp defaults/* /tmp/pkg/usr/share/trac/syn3_defaults
59mkdir /tmp/pkg/usr/bin
60cp syn3-newtrac /tmp/pkg/usr/bin || exit 1
61chmod +x /tmp/pkg/usr/bin/syn3-newtrac || exit 1
62
63#wsgi stuff
64mkdir -p /tmp/pkg//usr/share/trac/cgi-bin
65cp trac.wsgi /tmp/pkg//usr/share/trac/cgi-bin || exit 1
66
67#strip bins and other stuff
68syn3_strip /tmp/pkg || exit 1
69
70#move development stuff and create seperate development package
71syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
72syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
73
74#make main package
75syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
76
77
Note: See TracBrowser for help on using the repository browser.