source: npl/webapps/Trac_plugins/mastertickets/Trac_mastertickets.SlackBuild.dis @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.3 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7#DEP:python_setuptools
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15#Archive of the sourcefiles to unpack
16SRC_ARC=`ls *.zip`
17
18#Version of the sourcefiles
19VER=0.11
20
21#Directory of the sourcefiles to build (after optional unpacking)
22SRC_DIR=*/0.11                                                           
23
24#Architecture that the created binaries run on.
25#Use noarch for scripts.
26ARCH=`uname -m`
27
28
29########Build and create the pacakge.
30#Uncomment the stuff that you dont want or need
31
32#Unpack source
33#(uncomment if not needed)
34syn3_unpack $SRC_ARC || exit 1
35
36#apply patches
37#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
38
39pushd $SRC_DIR || exit 1
40python setup.py install --root=/tmp/pkg || exit 1
41popd
42
43#strip bins and other stuff
44syn3_strip /tmp/pkg || exit 1
45
46#move development stuff and create seperate development package
47syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
48syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
49
50#make main package
51syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
52
53
Note: See TracBrowser for help on using the repository browser.