source: npl/webapps/mediawiki/mediawiki.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
RevLine 
[c5c522c]1#!/bin/bash
2
3#######Essential package info.
4#Change these if autodetection fails.
5
6#Name of the Syn-3 package that we are going to create
7NAME=`basename $0|sed 's/.SlackBuild//'`
8
9#Archive of the sourcefiles to unpack
10SRC_ARC=`ls *.tar.*`
11
12#Version of the sourcefiles
13VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
14
15#Directory of the sourcefiles to build (after optional unpacking)
16SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
17
18#Architecture that the created binaries run on.
19#Use noarch for scripts.
20ARCH=`arch`
21
22
23########Build and create the pacakge.
24#Uncomment the stuff that you dont want or need
25
26#Unpack source
27#(uncomment if not needed)
28syn3_unpack $SRC_ARC || exit 1
29
30#apply patches
31#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
32
33#build and install sourcefiles
34#(use one of the other syn3_build_* scripts when needed)
35#export CONFIGURE_OPTS=""
36#export MAKE_OPTS=""
37#export NOTEST=1
38#syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
39
40mkdir -p /tmp/pkg/var/www/htdocs/syn3/mediawiki
41cp -r /tmp/build/mediawiki-*/* /tmp/pkg/var/www/htdocs/syn3/mediawiki/ ||exit 1
42cp /tmp/build/LocalSettings.php /tmp/pkg/var/www/htdocs/syn3/mediawiki/ ||exit 1
43cp /tmp/build/LdapAuthentication.php /tmp/pkg/var/www/htdocs/syn3/mediawiki/ ||exit 1
44#mkdir -p /tmp/pkg/tmp/
45cp /tmp/build/mediawiki.sql /tmp/pkg/var/www/htdocs/syn3/mediawiki ||exit 1
46
47#postinstall script (import mysql db)
48mkdir -p /tmp/pkg/etc/postinst.d/ ||exit 1
49cp /tmp/build/post.mediawiki /tmp/pkg/etc/postinst.d/ ||exit 1
50chmod +x /tmp/pkg/etc/postinst.d/post.mediawiki ||exit 1
51#mysql -u root -p ass < /tmp/mediawiki.sql
52chmod 700 /tmp/pkg/var/www/htdocs/syn3/mediawiki/mediawiki.sql
53
54#copy syn3 logo
55cp /tmp/build/logo.jpg /tmp/pkg/var/www/htdocs/syn3/mediawiki/images/
56
57#copy webportal files
58cp webportal.* /tmp/pkg/var/www/htdocs/syn3/mediawiki || exit 1
59
60#strip bins and other stuff
61syn3_strip /tmp/pkg || exit 1
62
63#move development stuff and create seperate development package
64syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
65syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
66
67#make main package
68syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
69
70
Note: See TracBrowser for help on using the repository browser.