Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/overig/curl/curl.SlackBuild.orig

    rc5c522c r105afb5  
    1 #!/bin/sh
     1#!/bin/bash
    22
    3 # Copyright 2008, 2009, 2010, 2011, 2013, 2014, 2016  Patrick J. Volkerding, Sebeka, MN, USA
     3# Copyright 2008, 2009, 2010, 2011, 2013, 2014, 2016, 2017, 2018, 2020, 2021  Patrick J. Volkerding, Sebeka, MN, USA
    44# All rights reserved.
    55#
     
    2121#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    2222
     23cd $(dirname $0) ; CWD=$(pwd)
    2324
    2425PKGNAM=curl
    25 VERSION=${VERSION:-$(echo curl-*.tar.bz2 | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
     26VERSION=${VERSION:-$(echo curl-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
    2627BUILD=${BUILD:-1}
    2728
     
    3637fi
    3738
    38 NUMJOBS=${NUMJOBS:-" -j7 "}
     39# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
     40# the name of the created package would be, and then exit. This information
     41# could be useful to other scripts.
     42if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
     43  echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
     44  exit 0
     45fi
    3946
    40 CWD=$(pwd)
     47NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
     48
    4149TMP=${TMP:-/tmp}
    4250PKG=$TMP/package-curl
    4351
    44 # Uncomment to build a no-SSL version:
    45 #SSLOPT=--without-ssl
     52# Set this variable to "--without-ssl" to build a no-SSL version:
     53SSLOPT=${SSLOPT:-"--with-openssl"}
    4654
    4755if [ "$ARCH" = "i586" ]; then
     
    6371cd $TMP
    6472rm -rf curl-$VERSION
    65 tar xvf $CWD/curl-$VERSION.tar.bz2 || exit 1
    66 cd curl-$VERSION
     73tar xvf $CWD/curl-$VERSION.tar.xz || exit 1
     74cd curl-$VERSION || exit 1
    6775
    6876chown -R root:root .
    6977find . \
    7078  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
    71   -exec chmod 755 {} \; -o \
     79  -exec chmod 755 {} \+ -o \
    7280  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
    73   -exec chmod 644 {} \;
     81  -exec chmod 644 {} \+
    7482
    7583CFLAGS="$SLKCFLAGS" \
     
    7886  --libdir=/usr/lib${LIBDIRSUFFIX} \
    7987  --mandir=/usr/man \
    80   --with-ca-bundle=/usr/share/curl/ca-bundle.crt \
     88  --with-gssapi \
    8189  --enable-static=no \
    82   $SSLOPT
     90  --without-ca-bundle \
     91  --with-ca-path=/etc/ssl/certs \
     92  $SSLOPT || exit 1
    8393
    8494make $NUMJOBS || make || exit 1
    8595make install DESTDIR=$PKG || exit 1
    8696
    87 mkdir -p $PKG/usr/share/curl
    88 cp -a $CWD/cacert.pem.bz2 $PKG/usr/share/curl
    89 ( cd $PKG/usr/share/curl
    90   bzip2 -d cacert.pem.bz2
    91   mv cacert.pem ca-bundle.crt
    92   chown root:root ca-bundle.crt
    93   chmod 644 ca-bundle.crt
     97# Don't ship .la files:
     98rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
     99
     100# We have always installed the man3 documentation, so we'll keep doing it
     101# even though these are no longer installed by default. No || exit 1, if
     102# it works, it works, and if it doesn't, we tried.
     103( cd docs/libcurl
     104  make install-man3 DESTDIR=$PKG
     105  cd opts
     106  make install-man3 DESTDIR=$PKG
    94107)
    95108
     
    104117mkdir -p $PKG/usr/doc/curl-$VERSION
    105118cp -a \
    106   COPYING* README* \
     119  COPYING* README*  \
    107120  $PKG/usr/doc/curl-$VERSION
    108 ( cd docs
    109   rm -rf Makefile* curl-config.1 curl-config.html curl.1 curl.html libcurl
    110   cp -a \
    111     BUGS  FAQ FEATURES INSTALL  MANUAL README* RESOURCES THANKS TODO examples \
    112     $PKG/usr/doc/curl-$VERSION )
    113121# Get rid of .deps cruft:
    114 rm -rf $PKG/usr/doc/curl-$VERSION/examples/.deps
     122rm -rf $PKG/usr/doc/curl-$VERSION/examples/.deps || true
    115123
    116124# If there's a CHANGES file, installing at least part of the recent history
Note: See TracChangeset for help on using the changeset viewer.