- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/internetserver/dhcp/dhcp.SlackBuild.orig
-
Property
mode
changed from
100755
to100644
rebc5ae5 r39a3656 1 #!/bin/ sh1 #!/bin/bash 2 2 3 # Copyright 2008, 2009, 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, MN, USA3 # Copyright 2008, 2009, 2010, 2011, 2012, 2017, 2018, 2020, 2021 Patrick J. Volkerding, Sebeka, MN, USA 4 4 # All rights reserved. 5 5 # … … 21 21 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 22 22 23 cd $(dirname $0) ; CWD=$(pwd) 23 24 24 25 PKGNAM=dhcp … … 30 31 PKG_VERSION=$(echo $VERSION | tr - _) 31 32 32 NUMJOBS=${NUMJOBS:-" -j 7"}33 NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "} 33 34 34 35 # Automatically determine the architecture we're building on: … … 42 43 fi 43 44 44 CWD=$(pwd) 45 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 46 # the name of the created package would be, and then exit. This information 47 # could be useful to other scripts. 48 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 49 echo "$PKGNAM-$PKG_VERSION-$ARCH-$BUILD.txz" 50 exit 0 51 fi 52 45 53 TMP=${TMP:-/tmp} 46 54 PKG=$TMP/package-dhcp 47 55 48 56 if [ "$ARCH" = "i586" ]; then 49 SLKCFLAGS="-O2 -march=i586 -mtune=i686 "57 SLKCFLAGS="-O2 -march=i586 -mtune=i686 -fcommon" 50 58 LIBDIRSUFFIX="" 51 59 elif [ "$ARCH" = "s390" ]; then 52 SLKCFLAGS="-O2 "60 SLKCFLAGS="-O2 -fcommon" 53 61 LIBDIRSUFFIX="" 54 62 elif [ "$ARCH" = "x86_64" ]; then 55 SLKCFLAGS="-O2 -fPIC "63 SLKCFLAGS="-O2 -fPIC -fcommon" 56 64 LIBDIRSUFFIX="64" 57 65 else 58 SLKCFLAGS="-O2 "66 SLKCFLAGS="-O2 -fcommon" 59 67 LIBDIRSUFFIX="" 60 68 fi … … 71 79 find . \ 72 80 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ 73 -exec chmod 755 {} \ ;-o \81 -exec chmod 755 {} \+ -o \ 74 82 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ 75 -exec chmod 644 {} \; 76 77 cat $CWD/dhcommon-getifaddrs.patch | patch -p1 || exit 1 83 -exec chmod 644 {} \+ 78 84 79 85 # Add PATH setting to /sbin/dhclient-script 80 86 zcat $CWD/dhclient-script.PATH.diff.gz | patch -p1 || exit 1 81 82 87 83 88 # Fix paths in manual pages … … 103 108 --with-srv6-lease-file=/var/state/dhcp/dhcpd6.leases \ 104 109 --with-cli-lease-file=/var/state/dhcp/dhclient.leases \ 105 --with-cli6-lease-file=/var/state/dhcp/dhclient6.leases 110 --with-cli6-lease-file=/var/state/dhcp/dhclient6.leases || exit 1 111 106 112 # Default pid dir is still /var/run, so no need to declare it 107 113 … … 163 169 LICENSE README RELNOTES \ 164 170 $PKG/usr/doc/dhcp-$VERSION 165 #mv $PKG/etc/dhcpd.conf $PKG/etc/dhclient.conf \166 # $PKG/usr/doc/dhcp-$VERSION/examples 171 mv $PKG/etc/dhcpd.conf $PKG/etc/dhclient.conf \ 172 $PKG/usr/doc/dhcp-$VERSION/examples || true 167 173 168 174 # If there's a ChangeLog, installing at least part of the recent history -
Property
mode
changed from
Note: See TracChangeset
for help on using the changeset viewer.